summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-voip/mumble/mumble-9999.ebuild')
-rw-r--r--net-voip/mumble/mumble-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-voip/mumble/mumble-9999.ebuild b/net-voip/mumble/mumble-9999.ebuild
index 8973f0ef46ff..cbe94df0b160 100644
--- a/net-voip/mumble/mumble-9999.ebuild
+++ b/net-voip/mumble/mumble-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake xdg
+inherit cmake flag-o-matic xdg
DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
HOMEPAGE="https://wiki.mumble.info"
@@ -106,6 +106,10 @@ src_configure() {
mycmakeargs+=( -DBUILD_NUMBER="$(ver_cut 3)" )
fi
+ # https://bugs.gentoo.org/832978
+ # fix tests (and possibly runtime issues) on arches with unsigned chars
+ append-cxxflags -fsigned-char
+
cmake_src_configure
}