summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/webkit-gtk/webkit-gtk-2.44.3.ebuild')
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.44.3.ebuild8
1 files changed, 1 insertions, 7 deletions
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.44.3.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.44.3.ebuild
index 8bb3bea943e0..1f69b75d4d31 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.44.3.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.44.3.ebuild
@@ -160,9 +160,6 @@ src_configure() {
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
use alpha && append-ldflags "-Wl,--no-relax"
- # ld segfaults on ia64 with LDFLAGS --as-needed, bug #555504
- use ia64 && append-ldflags "-Wl,--no-as-needed"
-
# Sigbuses on SPARC with mcpu and co., bug #???
use sparc && filter-flags "-mvis"
@@ -170,10 +167,7 @@ src_configure() {
use ppc64 && append-flags "-mminimal-toc"
# Try to use less memory, bug #469942 (see Fedora .spec for reference)
- # --no-keep-memory doesn't work on ia64, bug #502492
- if ! use ia64; then
- append-ldflags $(test-flags-CCLD "-Wl,--no-keep-memory")
- fi
+ append-ldflags $(test-flags-CCLD "-Wl,--no-keep-memory")
# Ruby situation is a bit complicated. See bug 513888
local rubyimpl