summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/tcpdump/tcpdump-4.9.2.ebuild')
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.9.2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-analyzer/tcpdump/tcpdump-4.9.2.ebuild b/net-analyzer/tcpdump/tcpdump-4.9.2.ebuild
index 14502772d423..519960e19cd4 100644
--- a/net-analyzer/tcpdump/tcpdump-4.9.2.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-4.9.2.ebuild
@@ -43,6 +43,15 @@ pkg_setup() {
fi
}
+src_prepare() {
+ default
+
+ sed -i -e '/^eapon1/d;' tests/TESTLIST || die
+
+ # bug 630394
+ sed -i -e '/^nbns-valgrind/d' tests/TESTLIST || die
+}
+
src_configure() {
if use drop-root; then
append-cppflags -DHAVE_CAP_NG_H
@@ -59,7 +68,6 @@ src_configure() {
src_test() {
if [[ ${EUID} -ne 0 ]] || ! use drop-root; then
- sed -i -e '/^\(espudp1\|eapon1\)/d;' tests/TESTLIST || die
emake check
else
ewarn "If you want to run the test suite, make sure you either"