summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pulseeffects/pulseeffects-5.0.0.ebuild')
-rw-r--r--media-sound/pulseeffects/pulseeffects-5.0.0.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/media-sound/pulseeffects/pulseeffects-5.0.0.ebuild b/media-sound/pulseeffects/pulseeffects-5.0.0.ebuild
index e717723570b7..bc49c613efc6 100644
--- a/media-sound/pulseeffects/pulseeffects-5.0.0.ebuild
+++ b/media-sound/pulseeffects/pulseeffects-5.0.0.ebuild
@@ -61,6 +61,17 @@ pkg_postinst() {
gnome2_gconf_install
gnome2_schemas_update
xdg_icon_cache_update
+ if [[ "${PV}" != 9999 ]]; then
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt "5.0.0"; then
+ if ver_test ${REPLACED_BY_VERSION} -ge "5.0.0"; then
+ elog "PulseEffects has switched to pipewire as it's audio backend"
+ elog "See https://wiki.gentoo.org/wiki/Pipewire for how to use the new backend"
+ fi
+ fi
+ done
+ fi
}
pkg_postrm() {