summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/dcd')
-rw-r--r--media-sound/dcd/dcd-0.95.ebuild25
-rw-r--r--media-sound/dcd/files/dcd-0.95-Wimplicit-function-declaration.patch20
-rw-r--r--media-sound/dcd/files/dcd-0.95-makefile.patch6
3 files changed, 35 insertions, 16 deletions
diff --git a/media-sound/dcd/dcd-0.95.ebuild b/media-sound/dcd/dcd-0.95.ebuild
index 9d4faecdeaa9..0f9f329da3ff 100644
--- a/media-sound/dcd/dcd-0.95.ebuild
+++ b/media-sound/dcd/dcd-0.95.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A simple command-line based CD Player"
HOMEPAGE="http://www.technopagan.org/dcd"
@@ -12,20 +12,21 @@ SRC_URI="http://www.technopagan.org/dcd/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ~ppc ppc64 sparc x86"
-IUSE=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-makefile.patch"
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
src_compile() {
- emake CC="$(tc-getCC)" CDROM="/dev/cdrom" EXTRA_CFLAGS="${CFLAGS}" || die "emake failed"
+ emake \
+ CC="$(tc-getCC)" \
+ CDROM="/dev/cdrom" \
+ EXTRA_CFLAGS="${CFLAGS}"
}
src_install() {
- dobin dcd || die "dobin failed"
+ dobin dcd
+ einstalldocs
doman dcd.1
- dodoc README BUGS ChangeLog
}
diff --git a/media-sound/dcd/files/dcd-0.95-Wimplicit-function-declaration.patch b/media-sound/dcd/files/dcd-0.95-Wimplicit-function-declaration.patch
new file mode 100644
index 000000000000..d3160424fc20
--- /dev/null
+++ b/media-sound/dcd/files/dcd-0.95-Wimplicit-function-declaration.patch
@@ -0,0 +1,20 @@
+--- a/dcd.c
++++ b/dcd.c
+@@ -23,6 +23,7 @@
+ #include <stdlib.h>
+ #include <ctype.h>
+ #include <getopt.h>
++#include <time.h>
+
+ #define ZERO 0
+ #define MAX_TRACKS 103
+--- a/screenop.c
++++ b/screenop.c
+@@ -10,6 +10,7 @@
+ #include "cdindex.h"
+ #include <unistd.h>
+ #include <stdio.h>
++#include <string.h>
+
+ void disk_directory(void) {
+ u_char ct = cd_current_track();
diff --git a/media-sound/dcd/files/dcd-0.95-makefile.patch b/media-sound/dcd/files/dcd-0.95-makefile.patch
index b59fedb6180c..c5ea478beb1d 100644
--- a/media-sound/dcd/files/dcd-0.95-makefile.patch
+++ b/media-sound/dcd/files/dcd-0.95-makefile.patch
@@ -1,7 +1,5 @@
-Index: dcd-0.95/Makefile
-===================================================================
---- dcd-0.95.orig/Makefile
-+++ dcd-0.95/Makefile
+--- a/Makefile
++++ b/Makefile
@@ -114,7 +114,7 @@ all: ${PROGS}
$(CC) -c $(CFLAGS) ${EXTRA_CFLAGS} $< -o $@