summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/plib/plib-1.8.5-r4.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/media-libs/plib/plib-1.8.5-r4.ebuild b/media-libs/plib/plib-1.8.5-r4.ebuild
index 3e4494514020..b5769bd1ab11 100644
--- a/media-libs/plib/plib-1.8.5-r4.ebuild
+++ b/media-libs/plib/plib-1.8.5-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -32,6 +32,12 @@ src_prepare() {
src_configure() {
append-cxxflags -std=c++03
+ # violates strict aliasing rules and is LTO-unsafe: https://bugs.gentoo.org/860048
+ # Per upstream in 2021, "PLIB has been obsolete and unmaintained for at LEAST 15 years!!"
+ # so this is getting fixed exactly never and getting worse.
+ append-cxxflags -fno-strict-aliasing
+ filter-lto
+
local myconf=(
--enable-shared
)