summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/ensemblist/ensemblist-040126.ebuild')
-rw-r--r--games-puzzle/ensemblist/ensemblist-040126.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-puzzle/ensemblist/ensemblist-040126.ebuild b/games-puzzle/ensemblist/ensemblist-040126.ebuild
new file mode 100644
index 000000000000..f54f3356f58f
--- /dev/null
+++ b/games-puzzle/ensemblist/ensemblist-040126.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Put together several primitives to build a given shape. (C.S.G. Game)"
+HOMEPAGE="http://www.nongnu.org/ensemblist/index_en.html"
+SRC_URI="http://savannah.nongnu.org/download/ensemblist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE=""
+
+DEPEND="media-libs/freeglut
+ media-libs/libmikmod:0
+ media-libs/libpng:0
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXmu"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ emake DATADIR="\"${GAMES_DATADIR}\"/${PN}/datas" \
+ CFLAGSLD="${LDFLAGS}"
+}
+
+src_install() {
+ dogamesbin ensemblist
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r datas
+ dodoc Changelog README
+ make_desktop_entry ${PN} Ensemblist
+ prepgamesdirs
+}