summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/koth')
-rw-r--r--games-action/koth/Manifest1
-rw-r--r--games-action/koth/files/koth-0.8.0-gcc-3.4.patch29
-rw-r--r--games-action/koth/koth-0.8.0.ebuild37
-rw-r--r--games-action/koth/metadata.xml8
4 files changed, 75 insertions, 0 deletions
diff --git a/games-action/koth/Manifest b/games-action/koth/Manifest
new file mode 100644
index 000000000000..d5c50fe3a9c8
--- /dev/null
+++ b/games-action/koth/Manifest
@@ -0,0 +1 @@
+DIST koth-0.8.0.tar.bz2 140569 SHA256 1f61e1c354ab2b425b33b1504fb181d8bf9e0b6e154c6d3a516b2f98f7c805d8 SHA512 edda377be9074298c63e85cad5f37f55dc67f0e9a7d075a94207559265ffbf8a5eadbd2dc0e4a06e535e6da9fcfd309d01141ba8be04cf8960b0229e0ce4ab9f WHIRLPOOL 0416e96f6e11fca4d567246184ab851dd4b225214c2982de4e966fb5d1274338956915571e2b53af1f1c0cd37b9a611fe468079550631f80f3b28de8f8c26870
diff --git a/games-action/koth/files/koth-0.8.0-gcc-3.4.patch b/games-action/koth/files/koth-0.8.0-gcc-3.4.patch
new file mode 100644
index 000000000000..4a858cbe03a9
--- /dev/null
+++ b/games-action/koth/files/koth-0.8.0-gcc-3.4.patch
@@ -0,0 +1,29 @@
+--- relay.c.old 2004-11-01 09:19:04.835537536 +0000
++++ relay.c 2004-11-01 09:19:59.453234384 +0000
+@@ -260,6 +260,7 @@
+ else goto bail;
+ goto nextpkt;
+ bail:
++ ;
+ }
+ }
+ }
+--- ballistics.c.old 2004-11-01 09:19:33.132235784 +0000
++++ ballistics.c 2004-11-01 09:20:16.849589736 +0000
+@@ -92,6 +92,7 @@
+ break;
+ case WALL_LAST:
+ /* just to satisfy gcc -Wall */
++ ;
+ }
+ }
+
+@@ -210,7 +211,7 @@
+ break;
+ case WALL_RANDOM: /* both of this can't happen, */
+ case WALL_LAST: /* so they are here to satisfy gcc -Wall */
+-
++ ;
+ }
+ }
+ return FLYING;
diff --git a/games-action/koth/koth-0.8.0.ebuild b/games-action/koth/koth-0.8.0.ebuild
new file mode 100644
index 000000000000..a3a78b6d5531
--- /dev/null
+++ b/games-action/koth/koth-0.8.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=4
+inherit eutils games
+
+DESCRIPTION="Multiplayer, networked game of little tanks with really big weapons"
+HOMEPAGE="http://www.nongnu.org/koth/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/default.pkg/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libggi"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's:-g -O2::' configure \
+ || die "sed configure failed"
+ cd src
+ epatch "${FILESDIR}"/${P}-gcc-3.4.patch
+ sed -i "s:/etc/koth:${GAMES_SYSCONFDIR}:" cfgfile.h \
+ || die "sed cfgfile.h failed"
+ sed -i 's:(uint16):(uint16_t):' gfx.c gfx.h \
+ || die "sed gfx.c gfx.h failed"
+}
+
+DOCS="AUTHORS ChangeLog NEWS README doc/*.txt"
+
+src_install() {
+ default
+ insinto "${GAMES_SYSCONFDIR}"
+ doins src/koth.cfg
+ prepgamesdirs
+}
diff --git a/games-action/koth/metadata.xml b/games-action/koth/metadata.xml
new file mode 100644
index 000000000000..fffb26d543b6
--- /dev/null
+++ b/games-action/koth/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+King of the Hill (KOTH) is a multiplayer, networked artillery game of little tanks with really big weapons set out to destroy one another. Best-known games of this type include the classic DOS game "Scorched Earth: The Mother of All Games" and "Scorched Tanks" for the Amiga.
+</longdescription>
+</pkgmetadata>