summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/vulkan-tools/vulkan-tools-1.1.77.0-r1.ebuild')
-rw-r--r--dev-util/vulkan-tools/vulkan-tools-1.1.77.0-r1.ebuild27
1 files changed, 26 insertions, 1 deletions
diff --git a/dev-util/vulkan-tools/vulkan-tools-1.1.77.0-r1.ebuild b/dev-util/vulkan-tools/vulkan-tools-1.1.77.0-r1.ebuild
index fcd605b2064e..2215b2e1cc55 100644
--- a/dev-util/vulkan-tools/vulkan-tools-1.1.77.0-r1.ebuild
+++ b/dev-util/vulkan-tools/vulkan-tools-1.1.77.0-r1.ebuild
@@ -22,7 +22,7 @@ HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Tools"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="X wayland"
+IUSE="+cube +vulkaninfo X wayland"
# Old packaging will cause file collisions
RDEPEND="!<=media-libs/vulkan-loader-1.1.70.0-r999"
@@ -36,9 +36,15 @@ DEPEND="${PYTHON_DEPS}
x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
)"
+# Vulkaninfo does not support wayland
+REQUIRED_USE="|| ( X wayland )
+ vulkaninfo? ( X )"
+
multilib_src_configure() {
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=True
+ -DBUILD_CUBE=$(usex cube)
+ -DBUILD_VULKANINFO=$(usex vulkaninfo)
-DBUILD_WSI_MIR_SUPPORT=False
-DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
-DBUILD_WSI_XCB_SUPPORT=$(usex X)
@@ -46,6 +52,25 @@ multilib_src_configure() {
-DGLSLANG_INSTALL_DIR="/usr"
-DVULKAN_HEADERS_INSTALL_DIR="/usr"
)
+
+ # Upstream only supports one window system at a time
+ # If X is set at all, even if wayland is set, use X
+ #
+ # If -cube and/or -vulkaninfo is set, the flags we set
+ # are ignored, so we don't need to consider that
+ if use X; then
+ mycmakeargs+=(
+ -DCUBE_WSI_SELECTION="XCB"
+ -DVULKANINFO_WSI_SELECTION="XCB"
+ )
+ fi
+
+ if ! use X && use wayland; then
+ mycmakeargs+=(
+ -DCUBE_WSI_SELECTION="WAYLAND"
+ )
+ fi
+
cmake-utils_src_configure
}