summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/akismet')
-rw-r--r--dev-ruby/akismet/Manifest2
-rw-r--r--dev-ruby/akismet/akismet-1.0.2.ebuild19
-rw-r--r--dev-ruby/akismet/akismet-2.0.0.ebuild22
-rw-r--r--dev-ruby/akismet/metadata.xml8
4 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/akismet/Manifest b/dev-ruby/akismet/Manifest
new file mode 100644
index 000000000000..4fe6740d99d7
--- /dev/null
+++ b/dev-ruby/akismet/Manifest
@@ -0,0 +1,2 @@
+DIST akismet-1.0.2.tar.gz 5567 SHA256 ddbbed326fb959aa85f8f09f11da4d5a2a6f30af7b830d9d15c9f90b582218ef SHA512 1cc5ef894a40c77eedaed3a6f2d1b778df0bb6cdc7d072ce35bd74b6e6871c830c1d83fc7faa85792208e1517723e3144973c7c05b74978476ef9854f8f27b6a WHIRLPOOL 188136b9943e70cb10f269f5bbc9e3cf4f68c6ac8fc9ffc1caf62b5b93b40d5c8c4fc9e089fe5d5cdc74f0c4ffe65c85035ca23147a0a8380de0137861faf295
+DIST akismet-2.0.0.tar.gz 8530 SHA256 e0080ab9e8737645689bd0ebe06d1b939397c74813103d32f69f6b49d7650076 SHA512 24066e88dfe6bd369b362da60677b8e4acc0785c99fd180e38ff0c11a83131dcb98bc22a7dbce5ff99c8841331fff487090c53bf480a787ec30e58ebba86c762 WHIRLPOOL 023e27aee98c90ef200db061b9fbd162fc74b417fac9f0aee8fd3484392cecf349e1abf7b51ad619fdb97ed2f05f0c121d854d771f8682d4bad2020f3bf9743b
diff --git a/dev-ruby/akismet/akismet-1.0.2.ebuild b/dev-ruby/akismet/akismet-1.0.2.ebuild
new file mode 100644
index 000000000000..c8a1d5d1c0ec
--- /dev/null
+++ b/dev-ruby/akismet/akismet-1.0.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby client for the Akismet API"
+HOMEPAGE="https://github.com/jonahb/akismet"
+SRC_URI="https://github.com/jonahb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
diff --git a/dev-ruby/akismet/akismet-2.0.0.ebuild b/dev-ruby/akismet/akismet-2.0.0.ebuild
new file mode 100644
index 000000000000..a446114eff44
--- /dev/null
+++ b/dev-ruby/akismet/akismet-2.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby client for the Akismet API"
+HOMEPAGE="https://github.com/jonahb/akismet"
+SRC_URI="https://github.com/jonahb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+# Tests now require an API key from akismet and a network connection.
+RESTRICT="test"
diff --git a/dev-ruby/akismet/metadata.xml b/dev-ruby/akismet/metadata.xml
new file mode 100644
index 000000000000..fb80028858a0
--- /dev/null
+++ b/dev-ruby/akismet/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">jonahb/akismet</remote-id>
+ </upstream>
+</pkgmetadata>