summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild')
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild b/dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild
index ca217b085352..191679505052 100644
--- a/dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild
+++ b/dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python2_7 )
CATKIN_HAS_MESSAGES=yes
ROS_SUBDIR=${PN}
-inherit ros-catkin
+inherit ros-catkin eutils
DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
LICENSE="Apache-2.0"
@@ -34,3 +34,12 @@ RDEPEND="
dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/gazebo-ros-2.7.3-patches-1.tar.bz2"
+
+src_prepare() {
+ pushd "${WORKDIR}/gazebo_ros_pkgs-${PV}" || die
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+ popd || die
+ ros-catkin_src_prepare
+}