summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild')
-rw-r--r--dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild b/dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild
index 11ea335900e4..ca0ceb79a286 100644
--- a/dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild
+++ b/dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/diagnostics"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -15,11 +14,13 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/roscpp
dev-ros/rostest[${PYTHON_USEDEP}]
dev-ros/std_msgs[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? ( dev-cpp/gtest dev-ros/rostest[${PYTHON_USEDEP}] )"