summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtspeech')
-rw-r--r--dev-qt/qtspeech/Manifest1
-rw-r--r--dev-qt/qtspeech/qtspeech-5.15.2.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-qt/qtspeech/Manifest b/dev-qt/qtspeech/Manifest
index 5244c976ef5d..8d287b67e161 100644
--- a/dev-qt/qtspeech/Manifest
+++ b/dev-qt/qtspeech/Manifest
@@ -1 +1,2 @@
DIST qtspeech-everywhere-src-5.15.1.tar.xz 101772 BLAKE2B 8a61ff9d5b0ba33ef3c82e26f3e4ae91ff0a6af848ae2bd26c0f0850cab0cbc701698c712e528cb6bb9a66ac699519f8235cb2c62edabc4506bf397ca747401c SHA512 0e2c82ea72b5bff5b36f3d833d80dec68b39f3b9c3ca4d9c9fa29f0419a45dfb19ac59fb105136c551f6bbe60ad32af0f4aaa6abafb5bc61bc5d85ecb94b326f
+DIST qtspeech-everywhere-src-5.15.2.tar.xz 101940 BLAKE2B 0b100fddac7bc880b79914be54a8618e3e31e9a2486e8cd4ab9f65eabaec605d9aba7c66f71569466798b9cc94e97a2e136868a6f8eda3208f9d0a9515e71ac9 SHA512 78a13218a639276c9b253566a1df52e2363847eac76df3962ba2a7178800206beb57859d22c7c99fa1579cb3aa7ab94baed1a6319ba946d4a64cba9e3bf52b05
diff --git a/dev-qt/qtspeech/qtspeech-5.15.2.ebuild b/dev-qt/qtspeech/qtspeech-5.15.2.ebuild
new file mode 100644
index 000000000000..12d0485fe59b
--- /dev/null
+++ b/dev-qt/qtspeech/qtspeech-5.15.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Text-to-speech library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+# TODO: flite plugin - needs 2.0.0 (not yet in tree)
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/speech-dispatcher-0.8.7
+ ~dev-qt/qtcore-${PV}
+"
+DEPEND="${RDEPEND}"