summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pillow/pillow-4.3.0-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-python/pillow/pillow-4.3.0-r1.ebuild b/dev-python/pillow/pillow-4.3.0-r1.ebuild
index 122241c36577..28006e3c4115 100644
--- a/dev-python/pillow/pillow-4.3.0-r1.ebuild
+++ b/dev-python/pillow/pillow-4.3.0-r1.ebuild
@@ -71,7 +71,15 @@ python_compile_all() {
python_test() {
"${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
- virtx nosetests -vx Tests/test_*.py
+ # These excluded tests below depend heavily on freetype being at the exact
+ # same as the one pinned upstream. However, pillow supports a wider range
+ # of freetype versions. These tests are more useful to upstream developer
+ # than to us. Disabling. See bug 593816.
+ virtx nosetests -vx \
+ -e "test_multiline_spacing" \
+ -e "test_render_multiline(_text)?" \
+ -e "test_textsize_equal" \
+ Tests/test_*.py
}
python_install() {