summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zeroconf/zeroconf-0.28.8.ebuild')
-rw-r--r--dev-python/zeroconf/zeroconf-0.28.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/zeroconf/zeroconf-0.28.8.ebuild b/dev-python/zeroconf/zeroconf-0.28.8.ebuild
new file mode 100644
index 000000000000..a37ea6ffc7a0
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.28.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # broken in network-sandbox
+ sed -e 's:test_launch_and_close:_&:' \
+ -e 's:test_integration_with_listener_ipv6:_&:' \
+ -i zeroconf/test.py || die
+ distutils-r1_src_prepare
+}