summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tomlkit')
-rw-r--r--dev-python/tomlkit/Manifest1
-rw-r--r--dev-python/tomlkit/tomlkit-0.11.8.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index 3312e8b2e158..13182ef443e9 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1,2 +1,3 @@
DIST tomlkit-0.11.6.tar.gz 188290 BLAKE2B c0fc64177dff2254ab4d377f15bada1093e69ed66f815b04f698359f096b123b256949e871344276e6fcda26e43ac22c505460c4f906505ea9676774cbfb0c5f SHA512 692f2facb18440609b63995f690f4ba29e82d696f5ce612f872499b4a42bb0ab33fcbf52abf36057c25448b3e29f30955dbc7e0ba34f10d21cb9b5d36e9ad9bf
DIST tomlkit-0.11.7.tar.gz 188555 BLAKE2B 1958ace56c37746585879f1b657af53f36d1b3e741a5e41438a9806897e252bfbf42040c65a05df6c1921413da3e68be6d5d6ef9ce0a0c5d457b170f1cce6528 SHA512 456de2047fe1da1905ebf6eed99bdbd7d565fab2ecb50b9c06655188271d52b3680882ce0db2beb69fa9e7d18548b8045a99c4897e12e1d92d9cf92a937864ab
+DIST tomlkit-0.11.8.tar.gz 188825 BLAKE2B 3b3b31f0243592ae28d3fc7c23bc6cd61eaa0d9907f4c7afc838e816783ac4ce28a0491c15c31649749272c8d65dd51b7a0160c8f0bf1e209115ebcb5ba13906 SHA512 538851d5460770000a1263fb2384dc8283f9fe56364ccebac2cef31be85c51056bbaf59c96134ceae624b978334c29b54653c28838567cd2806e70ec6e3e5856
diff --git a/dev-python/tomlkit/tomlkit-0.11.8.ebuild b/dev-python/tomlkit/tomlkit-0.11.8.ebuild
new file mode 100644
index 000000000000..f9911e9a934d
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.11.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="
+ https://github.com/sdispater/tomlkit/
+ https://pypi.org/project/tomlkit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "poetry' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "tomlkit"
+ version = "${PV}"
+ description = "Style preserving TOML library"
+ EOF
+}