summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-cov/pytest-cov-2.8.1.ebuild')
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.8.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild b/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild
index 45ad4ec70c7d..ac1732bd7f24 100644
--- a/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild
+++ b/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
inherit distutils-r1
@@ -35,6 +35,9 @@ DEPEND="
PATCHES=(
# Bug 597708
"${FILESDIR}/${PN}-2.8.1-disable-broken-tests.patch"
+ "${FILESDIR}/${PN}-2.8.1-latest-setuptools.patch"
+ # https://github.com/pytest-dev/pytest-cov/issues/365
+ "${FILESDIR}/pytest-cov-2.8.1-python38.patch"
)
distutils_enable_sphinx docs \