summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-10.0.1.9999.ebuild3
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-10.0.1_rc1.ebuild3
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1.9999.ebuild
index 52e3836cb57f..c87d9f13cf31 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1.9999.ebuild
@@ -50,6 +50,9 @@ src_prepare() {
# Python is needed to run tests using lit
python_setup
+ # cmake eclasses suck by forcing ${S} here
+ CMAKE_USE_DIR=${S} \
+ S=${WORKDIR} \
cmake-utils_src_prepare
}
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1_rc1.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1_rc1.ebuild
index 8a7efe8fca43..c228684d237c 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1_rc1.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1_rc1.ebuild
@@ -50,6 +50,9 @@ src_prepare() {
# Python is needed to run tests using lit
python_setup
+ # cmake eclasses suck by forcing ${S} here
+ CMAKE_USE_DIR=${S} \
+ S=${WORKDIR} \
cmake-utils_src_prepare
}
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
index a0e74a7dc12b..5a10d4d1de5c 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
@@ -50,6 +50,9 @@ src_prepare() {
# Python is needed to run tests using lit
python_setup
+ # cmake eclasses suck by forcing ${S} here
+ CMAKE_USE_DIR=${S} \
+ S=${WORKDIR} \
cmake-utils_src_prepare
}