summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_expect/ppx_expect-0.9.0-r1.ebuild')
-rw-r--r--dev-ml/ppx_expect/ppx_expect-0.9.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/ppx_expect/ppx_expect-0.9.0-r1.ebuild b/dev-ml/ppx_expect/ppx_expect-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..148c1674066c
--- /dev/null
+++ b/dev-ml/ppx_expect/ppx_expect-0.9.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Cram like framework for OCaml"
+HOMEPAGE="https://github.com/janestreet/ppx_expect"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-ml/base:=
+ dev-ml/ppx_assert:=
+ dev-ml/ppx_compare:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_custom_printf:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_fields_conv:=
+ dev-ml/ppx_here:=
+ dev-ml/ppx_inline_test:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_traverse:=
+ dev-ml/ppx_variants_conv:=
+ dev-ml/stdio:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/re:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/jbuilder"