summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/rocr-runtime/rocr-runtime-3.1.0.ebuild')
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-3.1.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-libs/rocr-runtime/rocr-runtime-3.1.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-3.1.0.ebuild
deleted file mode 100644
index d6ba469a09fe..000000000000
--- a/dev-libs/rocr-runtime/rocr-runtime-3.1.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/"
- inherit git-r3
- S="${WORKDIR}/${P}/src"
-else
- SRC_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/ROCR-Runtime-roc-${PV}/src"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="Radeon Open Compute Runtime"
-HOMEPAGE="https://github.com/RadeonOpenCompute/ROCR-Runtime"
-PATCHES=(
- "${FILESDIR}/${PN}-3.0.0-cmake-install-paths.patch"
-)
-
-LICENSE="MIT"
-SLOT="0/$(ver_cut 1-2)"
-IUSE="non-free"
-
-COMMON_DEPEND="sys-process/numactl"
-RDEPEND="${COMMON_DEPEND}
- non-free? ( dev-libs/hsa-ext-rocr )"
-DEPEND="${COMMON_DEPEND}
- >=dev-libs/roct-thunk-interface-${PV}"
-
-src_prepare() {
- sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
- cmake_src_prepare
-}