summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/th-orphans')
-rw-r--r--dev-haskell/th-orphans/Manifest2
-rw-r--r--dev-haskell/th-orphans/metadata.xml11
-rw-r--r--dev-haskell/th-orphans/th-orphans-0.11.1.ebuild30
-rw-r--r--dev-haskell/th-orphans/th-orphans-0.8.2.ebuild27
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-haskell/th-orphans/Manifest b/dev-haskell/th-orphans/Manifest
new file mode 100644
index 000000000000..e7ba2224fa77
--- /dev/null
+++ b/dev-haskell/th-orphans/Manifest
@@ -0,0 +1,2 @@
+DIST th-orphans-0.11.1.tar.gz 5511 SHA256 be0b88c2f83fb8a373498f95044ff9f9b68480cdc74e6bb11a256516f79e2c84 SHA512 49f3467ed2a8365ccd3ab2f3a7281e04a4b42fb81b6411f0553b1770974710df6005ecd3e3e41724ac02602c47150daad51010c107564d330d7b08cf52320503 WHIRLPOOL affe9e663744a332ef15cc740e4f29a4d884a6856f0ec23c42e173678b44189691372dc96f70f462252262e614c427428c1a77e3be3a72846db07880842af16c
+DIST th-orphans-0.8.2.tar.gz 4116 SHA256 de8db3117fae31e33e3125f66fbcb9cea514771da0a4c4922db6767a85a6a4a5 SHA512 d0cad737caebcf943a7289fd5ba771530553ff57d40dd3ac7dc7fb4ffe949ab04d7af660a3b84491366119ffdcf607819135bfd160c94a1f8401376d2b7b49a7 WHIRLPOOL 78e14f309ba12da10f8b93991e4ccb093cb1ca8143368b31058e7a48e342f20f25ca4a0707903a939e73abb2dc836ddacd28d446ba0417944d000caf9bd87383
diff --git a/dev-haskell/th-orphans/metadata.xml b/dev-haskell/th-orphans/metadata.xml
new file mode 100644
index 000000000000..2fa13b1b294a
--- /dev/null
+++ b/dev-haskell/th-orphans/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Orphan instances for TH datatypes. In particular, instances
+ for Ord and Lift, as well as a few missing Show / Eq. These
+ instances used to live in haskell-src-meta, and that&#39;s where
+ the version number started.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/th-orphans/th-orphans-0.11.1.ebuild b/dev-haskell/th-orphans/th-orphans-0.11.1.ebuild
new file mode 100644
index 000000000000..a8380f444216
--- /dev/null
+++ b/dev-haskell/th-orphans/th-orphans-0.11.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Orphan instances for TH datatypes"
+HOMEPAGE="http://hackage.haskell.org/package/th-orphans"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-haskell/nats-0.1:=[profile?] <dev-haskell/nats-2:=[profile?]
+ >=dev-haskell/th-lift-0.7.1:=[profile?]
+ >=dev-haskell/th-reify-many-0.1:=[profile?] <dev-haskell/th-reify-many-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/hspec )
+"
diff --git a/dev-haskell/th-orphans/th-orphans-0.8.2.ebuild b/dev-haskell/th-orphans/th-orphans-0.8.2.ebuild
new file mode 100644
index 000000000000..4dd337c93457
--- /dev/null
+++ b/dev-haskell/th-orphans/th-orphans-0.8.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Orphan instances for TH datatypes"
+HOMEPAGE="http://hackage.haskell.org/package/th-orphans"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/th-lift-0.5:=[profile?]
+ >=dev-haskell/th-reify-many-0.1:=[profile?] <dev-haskell/th-reify-many-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"