summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/quickcheck-instances')
-rw-r--r--dev-haskell/quickcheck-instances/Manifest3
-rw-r--r--dev-haskell/quickcheck-instances/metadata.xml23
-rw-r--r--dev-haskell/quickcheck-instances/quickcheck-instances-0.3.11.ebuild30
-rw-r--r--dev-haskell/quickcheck-instances/quickcheck-instances-0.3.8.ebuild29
-rw-r--r--dev-haskell/quickcheck-instances/quickcheck-instances-0.3.9.ebuild29
5 files changed, 114 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck-instances/Manifest b/dev-haskell/quickcheck-instances/Manifest
new file mode 100644
index 000000000000..e7e3e43a8e91
--- /dev/null
+++ b/dev-haskell/quickcheck-instances/Manifest
@@ -0,0 +1,3 @@
+DIST quickcheck-instances-0.3.11.tar.gz 6024 SHA256 02962005e51d77b84e94dd0a8f3f1be89af6e8099d25e6c0bf417f364c323a10 SHA512 a19c97810df7a028af5c6190f62bd9c858444ba210bd016eeb37b402aa9ff942a3538263b80d89a9c156189220ce32058fb81b384c1317f96df527654cb59818 WHIRLPOOL 8ccd4a400540ef70d60890b53e881b2f1fd232f5817640c4feaba365ddf4dca0c73af692b1e7c588544b3bde2e63461c32e359ebb0786ee5e55b40dcfabee330
+DIST quickcheck-instances-0.3.8.tar.gz 5725 SHA256 6fbe5a3ec9358b3a0a159528b568af6c0541320caabfa754f80a86f8cf506204 SHA512 c8ec49fdc4cc34ea1538c0e49945ede7b6e65897b80c4b9bbc28b3da420458e2731259344e3df02ab0d1afb757a0416dd8697c165af56bf899388491117b6287 WHIRLPOOL 5888baf24fbd40886150ae40877bd179c4eb79b592e689f3c29d9eac3a9cf77c7aaf47bc1eb4a3a5dd79b65c93507999510de3c436cd186e18dd119308f7ac59
+DIST quickcheck-instances-0.3.9.tar.gz 5768 SHA256 a618b0bce74594b060eb38e6fcc1479e71b91579a20374abb298a837435b15a8 SHA512 1a85f8c1e22307cff86456f5eee6ce8f5b394168b84868d220e721137ea4187822d4faface0116624e7ac99e8b716f6373903e913487712816e9829ca854c477 WHIRLPOOL 94966448ac0dc6cd16b40ef13e7554ef4c05e086db80a9dcc8f3f683aabc8282f45676a486407065b8695ce419644a1ddac17b0618deb2322388a479bd6e8cf9
diff --git a/dev-haskell/quickcheck-instances/metadata.xml b/dev-haskell/quickcheck-instances/metadata.xml
new file mode 100644
index 000000000000..4cf77d36fba1
--- /dev/null
+++ b/dev-haskell/quickcheck-instances/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ QuickCheck instances.
+
+ The goal is to supply QuickCheck instances for
+ types provided by the Haskell Platform.
+
+ Since all of these instances are provided as
+ orphans, I recommend that you do not use this library
+ within another library module, so that you don't
+ impose these instances on down-stream consumers of
+ your code.
+
+ For information on writing a test-suite with Cabal
+ see &lt;http://www.haskell.org/cabal/users-guide/#test-suites&gt;
+ </longdescription>
+ <upstream>
+ <remote-id type="github">aslatter/qc-instances</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.11.ebuild b/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.11.ebuild
new file mode 100644
index 000000000000..9f6f2d55ce5d
--- /dev/null
+++ b/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Common quickcheck instances"
+HOMEPAGE="https://github.com/aslatter/qc-instances"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.3:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ >=dev-haskell/old-time-1.0:=[profile?] <dev-haskell/old-time-1.2:=[profile?]
+ >=dev-haskell/quickcheck-2.1:2=[profile?] <dev-haskell/quickcheck-2.9:2=[profile?]
+ >=dev-haskell/text-0.7:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.1:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.8.ebuild b/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.8.ebuild
new file mode 100644
index 000000000000..f41ae6361497
--- /dev/null
+++ b/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Common quickcheck instances"
+HOMEPAGE="https://github.com/aslatter/qc-instances"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.3:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ >=dev-haskell/quickcheck-2.1:2=[profile?] <dev-haskell/quickcheck-2.8:2=[profile?]
+ >=dev-haskell/text-0.7:=[profile?] <dev-haskell/text-1.2:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.1:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.9.ebuild b/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.9.ebuild
new file mode 100644
index 000000000000..4e87909c9462
--- /dev/null
+++ b/dev-haskell/quickcheck-instances/quickcheck-instances-0.3.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Common quickcheck instances"
+HOMEPAGE="https://github.com/aslatter/qc-instances"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.3:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ >=dev-haskell/quickcheck-2.1:2=[profile?] <dev-haskell/quickcheck-2.8:2=[profile?]
+ >=dev-haskell/text-0.7:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.1:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"