summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/antlr-cpp/antlr-cpp-2.7.7-r2.ebuild4
-rw-r--r--dev-cpp/atkmm/atkmm-2.28.3.ebuild4
-rw-r--r--dev-cpp/benchmark/benchmark-1.8.2.ebuild2
-rw-r--r--dev-cpp/benchmark/benchmark-1.8.3.ebuild2
-rw-r--r--dev-cpp/cairomm/cairomm-1.14.4.ebuild4
-rw-r--r--dev-cpp/cairomm/cairomm-1.16.2.ebuild4
-rw-r--r--dev-cpp/cairomm/cairomm-1.18.0.ebuild4
-rw-r--r--dev-cpp/cli11/cli11-2.3.2.ebuild4
-rw-r--r--dev-cpp/clucene/clucene-2.3.3.4-r9.ebuild4
-rw-r--r--dev-cpp/eigen/eigen-3.4.0-r1.ebuild4
-rw-r--r--dev-cpp/glibmm/glibmm-2.66.6.ebuild4
-rw-r--r--dev-cpp/glibmm/glibmm-2.76.0.ebuild4
-rw-r--r--dev-cpp/glibmm/glibmm-2.78.0.ebuild2
-rw-r--r--dev-cpp/gstreamermm/gstreamermm-1.10.0-r1.ebuild4
-rw-r--r--dev-cpp/gtkmm/gtkmm-2.24.5-r1.ebuild4
-rw-r--r--dev-cpp/gtkmm/gtkmm-3.24.8.ebuild4
-rw-r--r--dev-cpp/gtkmm/gtkmm-4.10.0.ebuild4
-rw-r--r--dev-cpp/gtkmm/gtkmm-4.12.0.ebuild2
-rw-r--r--dev-cpp/gtksourceviewmm/gtksourceviewmm-3.18.0-r2.ebuild4
-rw-r--r--dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild4
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.42.2.ebuild4
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-5.0.3.ebuild4
-rw-r--r--dev-cpp/msgpack-cxx/msgpack-cxx-5.0.0.ebuild4
-rw-r--r--dev-cpp/msgpack-cxx/msgpack-cxx-6.0.0.ebuild4
-rw-r--r--dev-cpp/msgpack-cxx/msgpack-cxx-6.1.0.ebuild4
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.10.2.ebuild4
-rw-r--r--dev-cpp/pangomm/pangomm-2.46.3.ebuild4
-rw-r--r--dev-cpp/pangomm/pangomm-2.50.1.ebuild4
-rw-r--r--dev-cpp/sdbus-c++/sdbus-c++-1.4.0.ebuild4
-rw-r--r--dev-cpp/tclap/tclap-1.2.5.ebuild4
-rw-r--r--dev-cpp/waylandpp/waylandpp-1.0.0-r1.ebuild4
-rw-r--r--dev-cpp/waylandpp/waylandpp-1.0.0.ebuild4
-rw-r--r--dev-cpp/waylandpp/waylandpp-9999.ebuild4
-rw-r--r--dev-cpp/xsimd/xsimd-11.1.0-r1.ebuild4
-rw-r--r--dev-cpp/xsimd/xsimd-11.1.0.ebuild4
-rw-r--r--dev-cpp/xsimd/xsimd-12.1.1.ebuild4
36 files changed, 68 insertions, 68 deletions
diff --git a/dev-cpp/antlr-cpp/antlr-cpp-2.7.7-r2.ebuild b/dev-cpp/antlr-cpp/antlr-cpp-2.7.7-r2.ebuild
index 525a0ee06a08..c5a8534c2450 100644
--- a/dev-cpp/antlr-cpp/antlr-cpp-2.7.7-r2.ebuild
+++ b/dev-cpp/antlr-cpp/antlr-cpp-2.7.7-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,7 +18,7 @@ KEYWORDS="amd64 ~arm ppc x86"
IUSE="doc examples"
RESTRICT="test" # No tests but test target blows up!
-BDEPEND="doc? ( app-doc/doxygen[dot] )"
+BDEPEND="doc? ( app-text/doxygen[dot] )"
PATCHES=(
"${FILESDIR}"/${PV}-gcc.patch
diff --git a/dev-cpp/atkmm/atkmm-2.28.3.ebuild b/dev-cpp/atkmm/atkmm-2.28.3.ebuild
index a0b1f2ee8c64..0beb02b7b03d 100644
--- a/dev-cpp/atkmm/atkmm-2.28.3.ebuild
+++ b/dev-cpp/atkmm/atkmm-2.28.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,7 +24,7 @@ BDEPEND="
virtual/pkgconfig
gtk-doc? (
>=dev-cpp/mm-common-1.0.4
- app-doc/doxygen[dot]
+ app-text/doxygen[dot]
dev-libs/libxslt
)
${PYTHON_DEPS}
diff --git a/dev-cpp/benchmark/benchmark-1.8.2.ebuild b/dev-cpp/benchmark/benchmark-1.8.2.ebuild
index 70953bcb03f9..e87f23f14a3f 100644
--- a/dev-cpp/benchmark/benchmark-1.8.2.ebuild
+++ b/dev-cpp/benchmark/benchmark-1.8.2.ebuild
@@ -15,7 +15,7 @@ KEYWORDS="amd64 ~arm arm64 ~hppa ~loong ppc ppc64 ~riscv x86"
IUSE="debug doc test"
RESTRICT="!test? ( test )"
-BDEPEND="doc? ( app-doc/doxygen )
+BDEPEND="doc? ( app-text/doxygen )
test? ( >=dev-cpp/gtest-1.11.0 )"
src_configure() {
diff --git a/dev-cpp/benchmark/benchmark-1.8.3.ebuild b/dev-cpp/benchmark/benchmark-1.8.3.ebuild
index 097f257780d8..20e8f88dad8d 100644
--- a/dev-cpp/benchmark/benchmark-1.8.3.ebuild
+++ b/dev-cpp/benchmark/benchmark-1.8.3.ebuild
@@ -15,7 +15,7 @@ KEYWORDS="amd64 ~arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~x86"
IUSE="debug doc test"
RESTRICT="!test? ( test )"
-BDEPEND="doc? ( app-doc/doxygen )
+BDEPEND="doc? ( app-text/doxygen )
test? ( >=dev-cpp/gtest-1.11.0 )"
src_configure() {
diff --git a/dev-cpp/cairomm/cairomm-1.14.4.ebuild b/dev-cpp/cairomm/cairomm-1.14.4.ebuild
index 007d70bba611..c1b5939d9a91 100644
--- a/dev-cpp/cairomm/cairomm-1.14.4.ebuild
+++ b/dev-cpp/cairomm/cairomm-1.14.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,7 +30,7 @@ BDEPEND="
gtk-doc? (
${PYTHON_DEPS}
>=dev-cpp/mm-common-1.0.4
- app-doc/doxygen[dot]
+ app-text/doxygen[dot]
dev-libs/libxslt
)
"
diff --git a/dev-cpp/cairomm/cairomm-1.16.2.ebuild b/dev-cpp/cairomm/cairomm-1.16.2.ebuild
index 3c69fcb42aed..e28126d37356 100644
--- a/dev-cpp/cairomm/cairomm-1.16.2.ebuild
+++ b/dev-cpp/cairomm/cairomm-1.16.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,7 +30,7 @@ BDEPEND="
gtk-doc? (
${PYTHON_DEPS}
>=dev-cpp/mm-common-1.0.4
- app-doc/doxygen[dot]
+ app-text/doxygen[dot]
dev-libs/libxslt
)
"
diff --git a/dev-cpp/cairomm/cairomm-1.18.0.ebuild b/dev-cpp/cairomm/cairomm-1.18.0.ebuild
index c551d96c7702..56dc8295ef07 100644
--- a/dev-cpp/cairomm/cairomm-1.18.0.ebuild
+++ b/dev-cpp/cairomm/cairomm-1.18.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,7 +30,7 @@ BDEPEND="
gtk-doc? (
${PYTHON_DEPS}
>=dev-cpp/mm-common-1.0.4
- app-doc/doxygen[dot]
+ app-text/doxygen[dot]
dev-libs/libxslt
)
"
diff --git a/dev-cpp/cli11/cli11-2.3.2.ebuild b/dev-cpp/cli11/cli11-2.3.2.ebuild
index a11d4b8693e8..cd75dbc70626 100644
--- a/dev-cpp/cli11/cli11-2.3.2.ebuild
+++ b/dev-cpp/cli11/cli11-2.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,7 +23,7 @@ DEPEND="
)"
BDEPEND="
doc? (
- app-doc/doxygen
+ app-text/doxygen
media-gfx/graphviz
)"
diff --git a/dev-cpp/clucene/clucene-2.3.3.4-r9.ebuild b/dev-cpp/clucene/clucene-2.3.3.4-r9.ebuild
index b72a2580a52c..59eb684d8609 100644
--- a/dev-cpp/clucene/clucene-2.3.3.4-r9.ebuild
+++ b/dev-cpp/clucene/clucene-2.3.3.4-r9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,7 +18,7 @@ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc
IUSE="debug doc static-libs"
RESTRICT="test"
-BDEPEND="doc? ( >=app-doc/doxygen-1.4.2 )"
+BDEPEND="doc? ( >=app-text/doxygen-1.4.2 )"
DOCS=(AUTHORS ChangeLog README README.PACKAGE REQUESTS)
diff --git a/dev-cpp/eigen/eigen-3.4.0-r1.ebuild b/dev-cpp/eigen/eigen-3.4.0-r1.ebuild
index d55a7a350a56..c2124e3ffa08 100644
--- a/dev-cpp/eigen/eigen-3.4.0-r1.ebuild
+++ b/dev-cpp/eigen/eigen-3.4.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,7 +20,7 @@ RESTRICT="!test? ( test ) test"
BDEPEND="
doc? (
- app-doc/doxygen[dot]
+ app-text/doxygen[dot]
dev-texlive/texlive-bibtexextra
dev-texlive/texlive-fontsextra
dev-texlive/texlive-fontutils
diff --git a/dev-cpp/glibmm/glibmm-2.66.6.ebuild b/dev-cpp/glibmm/glibmm-2.66.6.ebuild
index 64bd4d9c4fa8..5132ce563e14 100644
--- a/dev-cpp/glibmm/glibmm-2.66.6.ebuild
+++ b/dev-cpp/glibmm/glibmm-2.66.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,7 +23,7 @@ BDEPEND="
${PYTHON_DEPS}
virtual/pkgconfig
gtk-doc? (
- app-doc/doxygen[dot]
+ app-text/doxygen[dot]
dev-lang/perl
dev-perl/XML-Parser
dev-libs/libxslt
diff --git a/dev-cpp/glibmm/glibmm-2.76.0.ebuild b/dev-cpp/glibmm/glibmm-2.76.0.ebuild
index 251ea2dfd81f..e84aeae04dfd 100644
--- a/dev-cpp/glibmm/glibmm-2.76.0.ebuild
+++ b/dev-cpp/glibmm/glibmm-2.76.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,7 +23,7 @@ BDEPEND="
${PYTHON_DEPS}
virtual/pkgconfig
gtk-doc? (
- app-doc/doxygen[dot]
+ app-text/doxygen[dot]
dev-lang/perl
dev-libs/libxslt
)
diff --git a/dev-cpp/glibmm/glibmm-2.78.0.ebuild b/dev-cpp/glibmm/glibmm-2.78.0.ebuild
index aa2e5023bcf0..f56533942e48 100644
--- a/dev-cpp/glibmm/glibmm-2.78.0.ebuild
+++ b/dev-cpp/glibmm/glibmm-2.78.0.ebuild
@@ -23,7 +23,7 @@ BDEPEND="
${PYTHON_DEPS}
virtual/pkgconfig
gtk-doc? (
- app-doc/doxygen[dot]
+ app-text/doxygen[dot]
dev-lang/perl
dev-libs/libxslt
)
diff --git a/dev-cpp/gstreamermm/gstreamermm-1.10.0-r1.ebuild b/dev-cpp/gstreamermm/gstreamermm-1.10.0-r1.ebuild
index 8f28a2ec3d97..a950c1971927 100644
--- a/dev-cpp/gstreamermm/gstreamermm-1.10.0-r1.ebuild
+++ b/dev-cpp/gstreamermm/gstreamermm-1.10.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,7 +25,7 @@ DEPEND="${RDEPEND}
dev-cpp/mm-common
virtual/pkgconfig
doc? (
- app-doc/doxygen
+ app-text/doxygen
dev-libs/libxslt
media-gfx/graphviz )
test? (
diff --git a/dev-cpp/gtkmm/gtkmm-2.24.5-r1.ebuild b/dev-cpp/gtkmm/gtkmm-2.24.5-r1.ebuild
index 6ed07f3d5f82..d70b1362ca74 100644
--- a/dev-cpp/gtkmm/gtkmm-2.24.5-r1.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-2.24.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,7 +28,7 @@ DEPEND="${RDEPEND}
doc? (
media-gfx/graphviz
dev-libs/libxslt
- app-doc/doxygen )
+ app-text/doxygen )
"
src_prepare() {
diff --git a/dev-cpp/gtkmm/gtkmm-3.24.8.ebuild b/dev-cpp/gtkmm/gtkmm-3.24.8.ebuild
index 5169cfc4db3f..f0d1a12ae4bb 100644
--- a/dev-cpp/gtkmm/gtkmm-3.24.8.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-3.24.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,7 +30,7 @@ DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
gtk-doc? (
- app-doc/doxygen[dot]
+ app-text/doxygen[dot]
dev-lang/perl
dev-libs/libxslt
)
diff --git a/dev-cpp/gtkmm/gtkmm-4.10.0.ebuild b/dev-cpp/gtkmm/gtkmm-4.10.0.ebuild
index 1e33a244be60..c24314dd8d40 100644
--- a/dev-cpp/gtkmm/gtkmm-4.10.0.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-4.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,7 +31,7 @@ DEPEND="
BDEPEND="
virtual/pkgconfig
gtk-doc? (
- app-doc/doxygen[dot]
+ app-text/doxygen[dot]
dev-lang/perl
dev-libs/libxslt
)
diff --git a/dev-cpp/gtkmm/gtkmm-4.12.0.ebuild b/dev-cpp/gtkmm/gtkmm-4.12.0.ebuild
index 54b584e8c512..0041d586a6df 100644
--- a/dev-cpp/gtkmm/gtkmm-4.12.0.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-4.12.0.ebuild
@@ -31,7 +31,7 @@ DEPEND="
BDEPEND="
virtual/pkgconfig
gtk-doc? (
- app-doc/doxygen[dot]
+ app-text/doxygen[dot]
dev-lang/perl
dev-libs/libxslt
)
diff --git a/dev-cpp/gtksourceviewmm/gtksourceviewmm-3.18.0-r2.ebuild b/dev-cpp/gtksourceviewmm/gtksourceviewmm-3.18.0-r2.ebuild
index 25437c7d3f99..ecafc2003471 100644
--- a/dev-cpp/gtksourceviewmm/gtksourceviewmm-3.18.0-r2.ebuild
+++ b/dev-cpp/gtksourceviewmm/gtksourceviewmm-3.18.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,7 +25,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- doc? ( app-doc/doxygen )
+ doc? ( app-text/doxygen )
"
src_configure() {
diff --git a/dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild b/dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild
index 82107fc5f404..a3b24a464bd2 100644
--- a/dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild
+++ b/dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,7 +27,7 @@ DEPEND="
"
RDEPEND="${DEPEND}"
BDEPEND="
- doc? ( app-doc/doxygen[dot] )
+ doc? ( app-text/doxygen[dot] )
test? ( dev-cpp/gtest )
"
RESTRICT="
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.42.2.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.42.2.ebuild
index 95baea814298..ab3e7f24e905 100644
--- a/dev-cpp/libxmlpp/libxmlpp-2.42.2.ebuild
+++ b/dev-cpp/libxmlpp/libxmlpp-2.42.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,7 +24,7 @@ BDEPEND="
virtual/pkgconfig
doc? (
dev-cpp/mm-common
- app-doc/doxygen
+ app-text/doxygen
media-gfx/graphviz
dev-libs/libxslt
)
diff --git a/dev-cpp/libxmlpp/libxmlpp-5.0.3.ebuild b/dev-cpp/libxmlpp/libxmlpp-5.0.3.ebuild
index 36dc8cb723d2..0cb0f12fdbdf 100644
--- a/dev-cpp/libxmlpp/libxmlpp-5.0.3.ebuild
+++ b/dev-cpp/libxmlpp/libxmlpp-5.0.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,7 +23,7 @@ BDEPEND="
virtual/pkgconfig
doc? (
dev-cpp/mm-common
- app-doc/doxygen
+ app-text/doxygen
media-gfx/graphviz
dev-libs/libxslt
)
diff --git a/dev-cpp/msgpack-cxx/msgpack-cxx-5.0.0.ebuild b/dev-cpp/msgpack-cxx/msgpack-cxx-5.0.0.ebuild
index 115ef8007e94..caf19cd7e8f6 100644
--- a/dev-cpp/msgpack-cxx/msgpack-cxx-5.0.0.ebuild
+++ b/dev-cpp/msgpack-cxx/msgpack-cxx-5.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,7 +21,7 @@ RESTRICT="!test? ( test )"
RDEPEND="boost? ( dev-libs/boost[context] )
!<dev-libs/msgpack-5.0.0"
DEPEND="${RDEPEND}"
-BDEPEND="doc? ( app-doc/doxygen[dot] )
+BDEPEND="doc? ( app-text/doxygen[dot] )
test? ( sys-libs/zlib )"
src_configure() {
diff --git a/dev-cpp/msgpack-cxx/msgpack-cxx-6.0.0.ebuild b/dev-cpp/msgpack-cxx/msgpack-cxx-6.0.0.ebuild
index d28443c3f1fa..35b5204d39c0 100644
--- a/dev-cpp/msgpack-cxx/msgpack-cxx-6.0.0.ebuild
+++ b/dev-cpp/msgpack-cxx/msgpack-cxx-6.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,7 +21,7 @@ RESTRICT="!test? ( test )"
RDEPEND="boost? ( dev-libs/boost[context] )
!<dev-libs/msgpack-5.0.0"
DEPEND="${RDEPEND}"
-BDEPEND="doc? ( app-doc/doxygen[dot] )
+BDEPEND="doc? ( app-text/doxygen[dot] )
test? ( sys-libs/zlib )"
PATCHES=(
diff --git a/dev-cpp/msgpack-cxx/msgpack-cxx-6.1.0.ebuild b/dev-cpp/msgpack-cxx/msgpack-cxx-6.1.0.ebuild
index 115ef8007e94..caf19cd7e8f6 100644
--- a/dev-cpp/msgpack-cxx/msgpack-cxx-6.1.0.ebuild
+++ b/dev-cpp/msgpack-cxx/msgpack-cxx-6.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,7 +21,7 @@ RESTRICT="!test? ( test )"
RDEPEND="boost? ( dev-libs/boost[context] )
!<dev-libs/msgpack-5.0.0"
DEPEND="${RDEPEND}"
-BDEPEND="doc? ( app-doc/doxygen[dot] )
+BDEPEND="doc? ( app-text/doxygen[dot] )
test? ( sys-libs/zlib )"
src_configure() {
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.10.2.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.10.2.ebuild
index f7a64254bd24..6e651fc5dfcb 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.10.2.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.10.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,7 +24,7 @@ IUSE="doc test"
# Tests only just added, large test suite, majority pass
RESTRICT="test"
-BDEPEND="doc? ( app-doc/doxygen )"
+BDEPEND="doc? ( app-text/doxygen )"
DOCS=( ChangeLog.md README.md )
diff --git a/dev-cpp/pangomm/pangomm-2.46.3.ebuild b/dev-cpp/pangomm/pangomm-2.46.3.ebuild
index 6adc2495e0f7..8b815a510093 100644
--- a/dev-cpp/pangomm/pangomm-2.46.3.ebuild
+++ b/dev-cpp/pangomm/pangomm-2.46.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,7 +25,7 @@ BDEPEND="
virtual/pkgconfig
gtk-doc? (
>=dev-cpp/mm-common-1.0.4
- app-doc/doxygen[dot]
+ app-text/doxygen[dot]
dev-libs/libxslt
)
${PYTHON_DEPS}
diff --git a/dev-cpp/pangomm/pangomm-2.50.1.ebuild b/dev-cpp/pangomm/pangomm-2.50.1.ebuild
index 7efb68a4b3ce..c1015ac58a90 100644
--- a/dev-cpp/pangomm/pangomm-2.50.1.ebuild
+++ b/dev-cpp/pangomm/pangomm-2.50.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,7 +25,7 @@ BDEPEND="
virtual/pkgconfig
gtk-doc? (
>=dev-cpp/mm-common-1.0.4
- app-doc/doxygen[dot]
+ app-text/doxygen[dot]
dev-libs/libxslt
)
${PYTHON_DEPS}
diff --git a/dev-cpp/sdbus-c++/sdbus-c++-1.4.0.ebuild b/dev-cpp/sdbus-c++/sdbus-c++-1.4.0.ebuild
index 1a01fb800da2..287759bdb75c 100644
--- a/dev-cpp/sdbus-c++/sdbus-c++-1.4.0.ebuild
+++ b/dev-cpp/sdbus-c++/sdbus-c++-1.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -28,7 +28,7 @@ DEPEND="
BDEPEND="
virtual/pkgconfig
- doc? ( app-doc/doxygen[dot] )
+ doc? ( app-text/doxygen[dot] )
"
S="${WORKDIR}/sdbus-cpp-${PV}"
diff --git a/dev-cpp/tclap/tclap-1.2.5.ebuild b/dev-cpp/tclap/tclap-1.2.5.ebuild
index b25e71c2dc4c..f1e436daeda7 100644
--- a/dev-cpp/tclap/tclap-1.2.5.ebuild
+++ b/dev-cpp/tclap/tclap-1.2.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2007-2022 Gentoo Authors
+# Copyright 2007-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~hppa ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux"
IUSE="doc"
-BDEPEND="doc? ( app-doc/doxygen )"
+BDEPEND="doc? ( app-text/doxygen )"
src_configure() {
econf $(use_enable doc doxygen)
diff --git a/dev-cpp/waylandpp/waylandpp-1.0.0-r1.ebuild b/dev-cpp/waylandpp/waylandpp-1.0.0-r1.ebuild
index 6ba27d433755..366b2ef8b527 100644
--- a/dev-cpp/waylandpp/waylandpp-1.0.0-r1.ebuild
+++ b/dev-cpp/waylandpp/waylandpp-1.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,7 +27,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}
doc? (
- app-doc/doxygen
+ app-text/doxygen
media-gfx/graphviz
)
"
diff --git a/dev-cpp/waylandpp/waylandpp-1.0.0.ebuild b/dev-cpp/waylandpp/waylandpp-1.0.0.ebuild
index 1cb87ff01ab5..eb1b99ee4e28 100644
--- a/dev-cpp/waylandpp/waylandpp-1.0.0.ebuild
+++ b/dev-cpp/waylandpp/waylandpp-1.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,7 +27,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}
doc? (
- app-doc/doxygen
+ app-text/doxygen
media-gfx/graphviz
)
"
diff --git a/dev-cpp/waylandpp/waylandpp-9999.ebuild b/dev-cpp/waylandpp/waylandpp-9999.ebuild
index ed2592fab36d..5cdaa6a0078f 100644
--- a/dev-cpp/waylandpp/waylandpp-9999.ebuild
+++ b/dev-cpp/waylandpp/waylandpp-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,7 +27,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}
doc? (
- app-doc/doxygen
+ app-text/doxygen
media-gfx/graphviz
)
"
diff --git a/dev-cpp/xsimd/xsimd-11.1.0-r1.ebuild b/dev-cpp/xsimd/xsimd-11.1.0-r1.ebuild
index 6dc53f557f5f..d668864520cd 100644
--- a/dev-cpp/xsimd/xsimd-11.1.0-r1.ebuild
+++ b/dev-cpp/xsimd/xsimd-11.1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,7 +18,7 @@ RESTRICT="!test? ( test )"
BDEPEND="
doc? (
- app-doc/doxygen
+ app-text/doxygen
dev-python/breathe
dev-python/sphinx
dev-python/sphinx-rtd-theme
diff --git a/dev-cpp/xsimd/xsimd-11.1.0.ebuild b/dev-cpp/xsimd/xsimd-11.1.0.ebuild
index 29217564ceda..1ba5b6165117 100644
--- a/dev-cpp/xsimd/xsimd-11.1.0.ebuild
+++ b/dev-cpp/xsimd/xsimd-11.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,7 +18,7 @@ RESTRICT="!test? ( test )"
BDEPEND="
doc? (
- app-doc/doxygen
+ app-text/doxygen
dev-python/breathe
dev-python/sphinx
dev-python/sphinx-rtd-theme
diff --git a/dev-cpp/xsimd/xsimd-12.1.1.ebuild b/dev-cpp/xsimd/xsimd-12.1.1.ebuild
index 36841823861d..f0516fd8e147 100644
--- a/dev-cpp/xsimd/xsimd-12.1.1.ebuild
+++ b/dev-cpp/xsimd/xsimd-12.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,7 +18,7 @@ RESTRICT="!test? ( test )"
BDEPEND="
doc? (
- app-doc/doxygen
+ app-text/doxygen
dev-python/breathe
dev-python/sphinx
dev-python/sphinx-rtd-theme