summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build/ignition-cmake/ignition-cmake-2.17.2.ebuild')
-rw-r--r--dev-build/ignition-cmake/ignition-cmake-2.17.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-build/ignition-cmake/ignition-cmake-2.17.2.ebuild b/dev-build/ignition-cmake/ignition-cmake-2.17.2.ebuild
new file mode 100644
index 000000000000..ff5c18e44d22
--- /dev/null
+++ b/dev-build/ignition-cmake/ignition-cmake-2.17.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="CMake modules to be used by the Ignition projects"
+HOMEPAGE="https://github.com/ignitionrobotics/ign-cmake"
+SRC_URI="https://github.com/gazebosim/gz-cmake/archive/refs/tags/${PN}2_${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/protobuf.patch" )
+S="${WORKDIR}/gz-cmake-${PN}2_${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DBUILD_TESTING=$(usex test)"
+ )
+ cmake_src_configure
+}