summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build/cmake/cmake-3.30.0.ebuild')
-rw-r--r--dev-build/cmake/cmake-3.30.0.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-build/cmake/cmake-3.30.0.ebuild b/dev-build/cmake/cmake-3.30.0.ebuild
index c119ad22dc76..7957c7bb58b2 100644
--- a/dev-build/cmake/cmake-3.30.0.ebuild
+++ b/dev-build/cmake/cmake-3.30.0.ebuild
@@ -152,6 +152,14 @@ src_prepare() {
sed -i -e '/define CMAKE_USE_XCODE/s/XCODE/NO_XCODE/' \
-e '/cmGlobalXCodeGenerator.h/d' \
Source/cmake.cxx || die
+ # Disable system integration, bug #933744
+ sed -i -e 's/__APPLE__/__DISABLED__/' \
+ Source/cmFindProgramCommand.cxx \
+ Source/CPack/cmCPackGeneratorFactory.cxx || die
+ sed -i -e 's/__MAC_OS_X_VERSION_MIN_REQUIRED/__DISABLED__/' \
+ Source/cmMachO.cxx || die
+ sed -i -e 's:CPack/cmCPack\(Bundle\|DragNDrop\|PKG\|ProductBuild\)Generator.cxx::' \
+ Source/CMakeLists.txt || die
# Disable isysroot usage with GCC, we've properly instructed
# where things are via GCC configuration and ldwrapper