summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/rnc2rng/rnc2rng-2.6.1.ebuild')
-rw-r--r--app-text/rnc2rng/rnc2rng-2.6.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-text/rnc2rng/rnc2rng-2.6.1.ebuild b/app-text/rnc2rng/rnc2rng-2.6.1.ebuild
new file mode 100644
index 000000000000..30df505f088a
--- /dev/null
+++ b/app-text/rnc2rng/rnc2rng-2.6.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="RELAX NG Compact to regular syntax conversion library"
+HOMEPAGE="https://github.com/djc/rnc2rng"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/rply[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ "${PYTHON}" test.py
+}