summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/gocr')
-rw-r--r--app-text/gocr/Manifest2
-rw-r--r--app-text/gocr/gocr-0.49.ebuild46
-rw-r--r--app-text/gocr/gocr-0.50.ebuild46
-rw-r--r--app-text/gocr/metadata.xml5
4 files changed, 99 insertions, 0 deletions
diff --git a/app-text/gocr/Manifest b/app-text/gocr/Manifest
new file mode 100644
index 000000000000..3e4b47b5e4b5
--- /dev/null
+++ b/app-text/gocr/Manifest
@@ -0,0 +1,2 @@
+DIST gocr-0.49.tar.gz 392386 SHA256 cc29931d50b3be11608dc79d1c7d8a20919dbe6313b1ba5dc88ecf99cffd171a SHA512 4559ab2cb05d67212da1857a9e7280abea0b4a172454d5145f04f7d23237d065c7b17ea110123ebbea5d62e589c507e73957e1b15e856b19f9bfc5efbecf467c WHIRLPOOL b62b991d63846b7a1f953b0251a7821bb7c9728633197d4e05e3f9276988d9db62f61e8242948abc5089b2f71f33d9480a8c79e4b4d12cbb4d53a39b73ed6806
+DIST gocr-0.50.tar.gz 419209 SHA256 bc261244f887419cba6d962ec1ad58eefd77176885093c4a43061e7fd565f5b5 SHA512 36392516711d43f8561147684b6f4e22a450bc87f1cb30ceaab4a1821ac583ff5a3d25b3bbf1637f01bfb55366b45cc7d5086d1f29f006d615bb658d0e5faab9 WHIRLPOOL d15b08eda68a27259c22c4f50d05e6d2bda7d1ad42c486279fa34a94b915ce52328f8fa6202cdf93bade2023d85be86d9e5fdab5aaaff9a63d6a6f5ab63f3189
diff --git a/app-text/gocr/gocr-0.49.ebuild b/app-text/gocr/gocr-0.49.ebuild
new file mode 100644
index 000000000000..c354feb2e830
--- /dev/null
+++ b/app-text/gocr/gocr-0.49.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="An OCR (Optical Character Recognition) reader"
+HOMEPAGE="http://jocr.sourceforge.net"
+SRC_URI="http://www-e.uni-magdeburg.de/jschulen/ocr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc scanner tk"
+
+DEPEND=">=media-libs/netpbm-9.12
+ doc? ( >=media-gfx/transfig-3.2 app-text/ghostscript-gpl )
+ tk? ( dev-lang/tk )"
+RDEPEND="${DEPEND}
+ tk? (
+ media-gfx/xli
+ scanner? ( media-gfx/xsane )
+ )"
+
+src_compile() {
+ local mymakes="src man"
+
+ use doc && mymakes="${mymakes} doc examples"
+
+ emake ${mymakes}
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" exec_prefix="${EPREFIX}/usr" install
+ dodoc AUTHORS BUGS CREDITS HISTORY RE* TODO
+
+ # remove the tk frontend if tk is not selected
+ use tk || rm "${ED}"/usr/bin/gocr.tcl
+ # and install the documentation and examples
+ if use doc ; then
+ dodoc doc/gocr.html doc/examples.txt doc/unicode.txt
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.{fig,tex,pcx}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/app-text/gocr/gocr-0.50.ebuild b/app-text/gocr/gocr-0.50.ebuild
new file mode 100644
index 000000000000..4b86ea6bb7d8
--- /dev/null
+++ b/app-text/gocr/gocr-0.50.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="An OCR (Optical Character Recognition) reader"
+HOMEPAGE="http://jocr.sourceforge.net"
+SRC_URI="http://www-e.uni-magdeburg.de/jschulen/ocr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc scanner tk"
+
+DEPEND=">=media-libs/netpbm-9.12
+ doc? ( >=media-gfx/transfig-3.2 app-text/ghostscript-gpl )
+ tk? ( dev-lang/tk )"
+RDEPEND="${DEPEND}
+ tk? (
+ media-gfx/xli
+ scanner? ( media-gfx/xsane )
+ )"
+
+src_compile() {
+ local mymakes="src man"
+
+ use doc && mymakes="${mymakes} doc examples"
+
+ emake ${mymakes}
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" exec_prefix="${EPREFIX}/usr" install
+ dodoc AUTHORS BUGS CREDITS HISTORY RE* TODO
+
+ # remove the tk frontend if tk is not selected
+ use tk || rm "${ED}"/usr/bin/gocr.tcl
+ # and install the documentation and examples
+ if use doc ; then
+ dodoc doc/gocr.html doc/examples.txt doc/unicode.txt
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.{fig,tex,pcx}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/app-text/gocr/metadata.xml b/app-text/gocr/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/app-text/gocr/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>