summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus/ibus-1.5.23.ebuild')
-rw-r--r--app-i18n/ibus/ibus-1.5.23.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/app-i18n/ibus/ibus-1.5.23.ebuild b/app-i18n/ibus/ibus-1.5.23.ebuild
index d53729503b59..c1770f770aa2 100644
--- a/app-i18n/ibus/ibus-1.5.23.ebuild
+++ b/app-i18n/ibus/ibus-1.5.23.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -111,6 +111,14 @@ src_prepare() {
src_configure() {
local unicodedir="${EPREFIX}"/usr/share/unicode
+ local ucddir
+
+ if has_verson '<app-i18n/unicode-data-14.0.0-r1'; then
+ ucddir="${unicodedir}-data"
+ else
+ ucddir=${unicodedir}
+ fi
+
local python_conf=()
if use python; then
python_setup
@@ -135,7 +143,7 @@ src_configure() {
$(use_enable nls) \
$(use_enable test tests) \
$(use_enable unicode unicode-dict) \
- $(use_with unicode ucd-dir "${EPREFIX}/usr/share/unicode-data") \
+ $(use_with unicode ucd-dir "${ucddir}") \
$(use_enable vala) \
$(use_enable wayland) \
"${python_conf[@]}"