summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/libewf/files/libewf-20140608-fix-tmpdir-in-tests.patch33
-rw-r--r--app-forensics/libewf/libewf-20140608-r1.ebuild10
2 files changed, 39 insertions, 4 deletions
diff --git a/app-forensics/libewf/files/libewf-20140608-fix-tmpdir-in-tests.patch b/app-forensics/libewf/files/libewf-20140608-fix-tmpdir-in-tests.patch
new file mode 100644
index 000000000000..09a6948d7c79
--- /dev/null
+++ b/app-forensics/libewf/files/libewf-20140608-fix-tmpdir-in-tests.patch
@@ -0,0 +1,33 @@
+--- a/tests/test_read_write.sh
++++ b/tests/test_read_write.sh
+@@ -25,7 +25,7 @@ EXIT_FAILURE=1;
+ EXIT_IGNORE=77;
+
+ INPUT="input";
+-TMP="tmp";
++TMP=$(mktemp -ut);
+
+ LS="ls";
+ TR="tr";
+--- a/tests/test_read_write_delta.sh
++++ b/tests/test_read_write_delta.sh
+@@ -25,7 +25,7 @@ EXIT_FAILURE=1;
+ EXIT_IGNORE=77;
+
+ INPUT="input";
+-TMP="tmp";
++TMP=$(mktemp -ut);
+
+ AWK="awk";
+ CUT="cut";
+--- a/tests/test_write.sh
++++ b/tests/test_write.sh
+@@ -24,7 +24,7 @@ EXIT_SUCCESS=0;
+ EXIT_FAILURE=1;
+ EXIT_IGNORE=77;
+
+-TMP="tmp";
++TMP=$(mktemp -ut);
+
+ CUT="cut";
+
diff --git a/app-forensics/libewf/libewf-20140608-r1.ebuild b/app-forensics/libewf/libewf-20140608-r1.ebuild
index 4f45bb342f11..c313c72a60ad 100644
--- a/app-forensics/libewf/libewf-20140608-r1.ebuild
+++ b/app-forensics/libewf/libewf-20140608-r1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
inherit eutils autotools-utils
DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
@@ -27,9 +28,10 @@ DEPEND="
zlib? ( sys-libs/zlib )"
RDEPEND="${DEPEND}"
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-PATCHES=( "${DISTDIR}"/${P}-libuna-remove-inline.patch )
+PATCHES=(
+ "${DISTDIR}"/${P}-libuna-remove-inline.patch
+ "${FILESDIR}"/${PN}-20140608-fix-tmpdir-in-tests.patch
+)
DOCS=( AUTHORS ChangeLog NEWS README documents/header.txt documents/header2.txt )