summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/86Box')
-rw-r--r--app-emulation/86Box/86Box-3.6.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/app-emulation/86Box/86Box-3.6.ebuild b/app-emulation/86Box/86Box-3.6.ebuild
index 83e0de773c6f..78a19f937313 100644
--- a/app-emulation/86Box/86Box-3.6.ebuild
+++ b/app-emulation/86Box/86Box-3.6.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Emulator of x86-based machines based on PCem"
HOMEPAGE="https://github.com/86Box/86Box"
@@ -45,6 +45,10 @@ RDEPEND="
BDEPEND="virtual/pkgconfig"
src_configure() {
+ # LTO needs to be filtered
+ # See https://bugs.gentoo.org/854507
+ filter-lto
+
local mycmakeargs=(
-DCPPTHREADS="$(usex threads)"
-DDEV_BRANCH="$(usex experimental)"