summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/gjs/gjs-1.56.2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-libs/gjs/gjs-1.56.2.ebuild b/dev-libs/gjs/gjs-1.56.2.ebuild
index 071966de1530..d436481cec50 100644
--- a/dev-libs/gjs/gjs-1.56.2.ebuild
+++ b/dev-libs/gjs/gjs-1.56.2.ebuild
@@ -44,8 +44,9 @@ src_configure() {
$(use_with gtk) \
$(use_enable readline) \
$(use_with test dbus-tests) \
- $(use_with test xvfb-tests) \
- --disable-installed-tests
+ --disable-installed-tests \
+ --without-xvfb-tests
+ #$(use_with test xvfb-tests) # https://gitlab.gnome.org/GNOME/gjs/issues/280
}
src_install() {
@@ -62,5 +63,5 @@ src_install() {
}
src_test() {
- virtx default
+ virtx dbus-run-session emake check || die
}