summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/gkrellm-mailwatch/files/gkrellm-mailwatch-2.4.3-pkgconfig.patch16
-rw-r--r--x11-plugins/gkrellm-mailwatch/gkrellm-mailwatch-2.4.3-r3.ebuild35
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-mailwatch/files/gkrellm-mailwatch-2.4.3-pkgconfig.patch b/x11-plugins/gkrellm-mailwatch/files/gkrellm-mailwatch-2.4.3-pkgconfig.patch
new file mode 100644
index 000000000000..5607d1eae69d
--- /dev/null
+++ b/x11-plugins/gkrellm-mailwatch/files/gkrellm-mailwatch-2.4.3-pkgconfig.patch
@@ -0,0 +1,16 @@
+Have Makefile respect user-configured pkg-config
+--- a/Makefile
++++ b/Makefile
+@@ -1,10 +1,10 @@
+ # Makefile for the GKrellM mailwatch plugin
+
+-GTK_CONFIG ?=pkg-config gtk+-2.0
++PKG_CONFIG ?= pkg-config
+ PLUGIN_DIR ?=/usr/local/lib/gkrellm2/plugins
+
+-GTK_INCLUDE = `$(GTK_CONFIG) --cflags`
+-GTK_LIB = `$(GTK_CONFIG) --libs`
++GTK_INCLUDE = $(shell ${PKG_CONFIG} gtk+-2.0 --cflags)
++GTK_LIB = $(shell ${PKG_CONFIG} gtk+-2.0 --libs)
+
+ GKRELLM_INCLUDE= -I/usr/local/include
diff --git a/x11-plugins/gkrellm-mailwatch/gkrellm-mailwatch-2.4.3-r3.ebuild b/x11-plugins/gkrellm-mailwatch/gkrellm-mailwatch-2.4.3-r3.ebuild
new file mode 100644
index 000000000000..54c18b282740
--- /dev/null
+++ b/x11-plugins/gkrellm-mailwatch/gkrellm-mailwatch-2.4.3-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="A GKrellM2 plugin that shows the status of additional mail boxes"
+HOMEPAGE="http://gkrellm.luon.net/mailwatch.php"
+SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="app-admin/gkrellm:2[X]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/2.4.3-0001-Respect-LDFLAGS.patch
+ "${FILESDIR}"/2.4.3-0002-Use-gkrellm_gkd_string_width.patch
+ "${FILESDIR}"/2.4.3-0003-Remove-a-few-more-GCC-warnings.patch
+ "${FILESDIR}"/2.4.3-0004-Do-not-force-O2-in-CFLAGS.patch
+ "${FILESDIR}/${P}"-pkgconfig.patch
+)
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+
+ PLUGIN_SO=( mailwatch$(get_modname) )
+
+ default
+}