summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/hwloc/hwloc-1.11.13.ebuild6
-rw-r--r--sys-apps/hwloc/hwloc-2.3.0.ebuild6
-rw-r--r--sys-apps/hwloc/hwloc-2.5.0.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/sys-apps/hwloc/hwloc-1.11.13.ebuild b/sys-apps/hwloc/hwloc-1.11.13.ebuild
index f9b7aae544d1..151384ff11a5 100644
--- a/sys-apps/hwloc/hwloc-1.11.13.ebuild
+++ b/sys-apps/hwloc/hwloc-1.11.13.ebuild
@@ -43,8 +43,8 @@ src_prepare() {
eautoreconf
if use cuda ; then
- append-cflags -I"${EPREFIX}"/opt/cuda/include
- append-cppflags -I"${EPREFIX}"/opt/cuda/include
+ append-cflags -I"${ESYSROOT}"/opt/cuda/include
+ append-cppflags -I"${ESYSROOT}"/opt/cuda/include
fi
}
@@ -53,7 +53,7 @@ multilib_src_configure() {
if use cuda ; then
local -x LDFLAGS="${LDFLAGS}"
- append-ldflags -L"${EPREFIX}"/opt/cuda/$(get_libdir)
+ append-ldflags -L"${ESYSROOT}"/opt/cuda/$(get_libdir)
fi
ECONF_SOURCE=${S} econf \
diff --git a/sys-apps/hwloc/hwloc-2.3.0.ebuild b/sys-apps/hwloc/hwloc-2.3.0.ebuild
index 6756f4000ac9..f98a08eb4cda 100644
--- a/sys-apps/hwloc/hwloc-2.3.0.ebuild
+++ b/sys-apps/hwloc/hwloc-2.3.0.ebuild
@@ -48,8 +48,8 @@ src_prepare() {
eautoreconf
if use cuda ; then
- append-cflags "-I${EPREFIX}/opt/cuda/include"
- append-cppflags "-I${EPREFIX}/opt/cuda/include"
+ append-cflags "-I${ESYSROOT}/opt/cuda/include"
+ append-cppflags "-I${ESYSROOT}/opt/cuda/include"
fi
}
@@ -58,7 +58,7 @@ multilib_src_configure() {
if use cuda ; then
local -x LDFLAGS="${LDFLAGS}"
- append-ldflags "-L${EPREFIX}/opt/cuda/$(get_libdir)"
+ append-ldflags "-L${ESYSROOT}/opt/cuda/$(get_libdir)"
fi
local myconf=(
diff --git a/sys-apps/hwloc/hwloc-2.5.0.ebuild b/sys-apps/hwloc/hwloc-2.5.0.ebuild
index 6756f4000ac9..f98a08eb4cda 100644
--- a/sys-apps/hwloc/hwloc-2.5.0.ebuild
+++ b/sys-apps/hwloc/hwloc-2.5.0.ebuild
@@ -48,8 +48,8 @@ src_prepare() {
eautoreconf
if use cuda ; then
- append-cflags "-I${EPREFIX}/opt/cuda/include"
- append-cppflags "-I${EPREFIX}/opt/cuda/include"
+ append-cflags "-I${ESYSROOT}/opt/cuda/include"
+ append-cppflags "-I${ESYSROOT}/opt/cuda/include"
fi
}
@@ -58,7 +58,7 @@ multilib_src_configure() {
if use cuda ; then
local -x LDFLAGS="${LDFLAGS}"
- append-ldflags "-L${EPREFIX}/opt/cuda/$(get_libdir)"
+ append-ldflags "-L${ESYSROOT}/opt/cuda/$(get_libdir)"
fi
local myconf=(