summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/rosmake/Manifest1
-rw-r--r--dev-ros/rosmake/rosmake-1.15.5.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rosmake/Manifest b/dev-ros/rosmake/Manifest
index c9058151d490..ad9892918527 100644
--- a/dev-ros/rosmake/Manifest
+++ b/dev-ros/rosmake/Manifest
@@ -1 +1,2 @@
DIST ros-1.14.7.tar.gz 175854 BLAKE2B 713ad5036a14a27556c9cc68f12b737562148f786c5d5ac32ba8328a05d63df3154222762af1fba7db34b11123a2cdc6f3a23770f9ddf1f30a7d14ef47a26ecc SHA512 b4ea471586630754c5d212ec32c5d5d20b4bb25b707c69249bf976384eb23ad6e2fa95906167ce48c916ca4ab12747a031184073c70fe6986efcc3258a1f5498
+DIST ros-1.15.5.tar.gz 178252 BLAKE2B 2e96f550ee6d9e049db4a69464db0bf948f2baf8ea50b2105ac19dcd758e4fc57cb011529e28cd9058ccb4adcbcf087e6295f35e6f9c511f5f33c3ddbe27c2db SHA512 d526e267faf231c0c9153614a24f05294b648595bda6d99ea937ca3cca70b2784b26c3c62f9b4830322adbd17d8e151be314c7301b753450450c5c38527d48d3
diff --git a/dev-ros/rosmake/rosmake-1.15.5.ebuild b/dev-ros/rosmake/rosmake-1.15.5.ebuild
new file mode 100644
index 000000000000..68a65900edd9
--- /dev/null
+++ b/dev-ros/rosmake/rosmake-1.15.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS dependency aware build tool"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"