summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-wireless/gr-paint/Manifest2
-rw-r--r--net-wireless/gr-paint/gr-paint-0.0_p20230427.ebuild (renamed from net-wireless/gr-paint/gr-paint-0.0_p20220320-r1.ebuild)7
2 files changed, 6 insertions, 3 deletions
diff --git a/net-wireless/gr-paint/Manifest b/net-wireless/gr-paint/Manifest
index 06c2ea89ed35..fbb4636fd5a8 100644
--- a/net-wireless/gr-paint/Manifest
+++ b/net-wireless/gr-paint/Manifest
@@ -1 +1 @@
-DIST gr-paint-0.0_p20220320.tar.gz 2089721 BLAKE2B 50327bd2349177029e1c2fc3a7b3fe6df929487c456a6ae90f1233df7f8db02721bd0233e496cf4a00a9fa2164db705d995b1c2ec25e0a516a0672a6c2b5178d SHA512 b017fa41d8797182d752ad12bfe7511282d33bdfd87ea92dc86f6f01bbe5411759ed6bbfb0adb69368881fa231ee38e4c1eab47aebccdd64bd274f1f55ccac14
+DIST gr-paint-0.0_p20230427.tar.gz 2094691 BLAKE2B 1dfa5fce3d24911dd9802bd322d4e9916a13066e69e5a0b57201f679a4b9bb985d7ee570e1d3881ecced257927ceb9a3b3845bd60422f407a753482dd35bf0a3 SHA512 7be52c524cdfde8a9620102c9b8cbdd813443c7bd9db1466ec3b73c588bb685fdd917fd2d8c602237b1b0450922d8a058ba9d2d507194a7b1ed4efe0c8f0a5f5
diff --git a/net-wireless/gr-paint/gr-paint-0.0_p20220320-r1.ebuild b/net-wireless/gr-paint/gr-paint-0.0_p20230427.ebuild
index 591dda03c344..a60efdb36b71 100644
--- a/net-wireless/gr-paint/gr-paint-0.0_p20220320-r1.ebuild
+++ b/net-wireless/gr-paint/gr-paint-0.0_p20230427.ebuild
@@ -9,12 +9,12 @@ if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/drmpeg/gr-paint.git"
else
- COMMIT="6cf1568eb9e32c25bf6414ad45f75048a5a2b74c"
+ COMMIT="995e888fdd575853349b5c72824c216dace74937"
SRC_URI="https://github.com/drmpeg/gr-paint/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT}"
KEYWORDS="~amd64"
fi
-inherit cmake python-single-r1
+inherit cmake flag-o-matic python-single-r1
DESCRIPTION="Paints monochrome images into the waterfall of a receiver"
HOMEPAGE="https://github.com/drmpeg/gr-paint"
@@ -32,6 +32,7 @@ DEPEND="${PYTHON_DEPS}
dev-libs/boost:=[python,${PYTHON_USEDEP}]
')
dev-libs/gmp
+ dev-libs/spdlog:=
sci-libs/volk:=
sci-libs/fftw
>=net-wireless/gnuradio-3.9:=[${PYTHON_SINGLE_USEDEP}]
@@ -45,6 +46,8 @@ BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen )
"
+#https://github.com/drmpeg/gr-paint/issues/21
+append-cxxflags -U_GLIBCXX_ASSERTIONS
src_configure() {
local mycmakeargs=(