summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xvkbd/files/xvkbd-4.0-fno-common.patch22
-rw-r--r--x11-misc/xvkbd/xvkbd-4.0.ebuild3
2 files changed, 24 insertions, 1 deletions
diff --git a/x11-misc/xvkbd/files/xvkbd-4.0-fno-common.patch b/x11-misc/xvkbd/files/xvkbd-4.0-fno-common.patch
new file mode 100644
index 000000000000..1ca0db048566
--- /dev/null
+++ b/x11-misc/xvkbd/files/xvkbd-4.0-fno-common.patch
@@ -0,0 +1,22 @@
+--- a/resources.h
++++ b/resources.h
+@@ -19,7 +19,7 @@
+ # define PROGRAM_NAME "xvkbd"
+ #endif
+
+-struct appres_struct {
++extern struct appres_struct {
+ String description;
+ String show_manual_command;
+
+--- a/xvkbd.c
++++ b/xvkbd.c
+@@ -500,6 +500,8 @@
+
+ static Pixmap xvkbd_pixmap = None;
+
++struct appres_struct appres;
++
+ static int AddKeysym(KeySym keysym, Boolean top); /* forward */
+ static void MakeKeyboard(Boolean remake);
+ static void MakeKeypad(Widget form, Widget from_vert, Widget from_horiz);
diff --git a/x11-misc/xvkbd/xvkbd-4.0.ebuild b/x11-misc/xvkbd/xvkbd-4.0.ebuild
index 90d49c1f04fe..90be10d40308 100644
--- a/x11-misc/xvkbd/xvkbd-4.0.ebuild
+++ b/x11-misc/xvkbd/xvkbd-4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,6 +27,7 @@ DEPEND="
"
PATCHES=(
"${FILESDIR}"/${PN}-4.0-destdir.patch
+ "${FILESDIR}"/${PN}-4.0-fno-common.patch
)
src_prepare() {