summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/chump/chump-1.6.0-r1.ebuild22
-rw-r--r--dev-python/chump/chump-1.6.0.ebuild36
2 files changed, 22 insertions, 36 deletions
diff --git a/dev-python/chump/chump-1.6.0-r1.ebuild b/dev-python/chump/chump-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..b46f8078b775
--- /dev/null
+++ b/dev-python/chump/chump-1.6.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="API wrapper for Pushover"
+HOMEPAGE="https://github.com/karanlyons/chump"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# 'html_theme' is unset, meaning alabaster will be used
+# and sphinx depends on it
+distutils_enable_sphinx docs
+
+# The package has no test suite
diff --git a/dev-python/chump/chump-1.6.0.ebuild b/dev-python/chump/chump-1.6.0.ebuild
deleted file mode 100644
index 6ee3f01c296e..000000000000
--- a/dev-python/chump/chump-1.6.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="API wrapper for Pushover"
-HOMEPAGE="https://github.com/karanlyons/chump"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND="
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-# The package has no test suite
-
-python_prepare_all() {
- sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- # Force sphinx to use the standard theme
- READTHEDOCS=True sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}