summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/albert/files/albert-0.17.3-find-and-use-python-libraries-and-headers.patch33
-rw-r--r--x11-misc/albert/files/albert-0.20.13-use-system-qhotkey-libraries-and-headers.patch13
2 files changed, 0 insertions, 46 deletions
diff --git a/x11-misc/albert/files/albert-0.17.3-find-and-use-python-libraries-and-headers.patch b/x11-misc/albert/files/albert-0.17.3-find-and-use-python-libraries-and-headers.patch
deleted file mode 100644
index 943e5d8acf2d..000000000000
--- a/x11-misc/albert/files/albert-0.17.3-find-and-use-python-libraries-and-headers.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From aa89c47db62163eddea623beb48f7ffd8d76062c Mon Sep 17 00:00:00 2001
-From: Buchan Milne <bgmilne@gmail.com>
-Date: Thu, 14 Jun 2018 08:10:31 +0200
-Subject: [PATCH] Find and use python libraries and headers
-
----
- plugins/python/CMakeLists.txt | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/plugins/python/CMakeLists.txt b/plugins/python/CMakeLists.txt
-index 2dd085d..0dc9b91 100644
---- a/plugins/python/CMakeLists.txt
-+++ b/plugins/python/CMakeLists.txt
-@@ -5,7 +5,8 @@ PROJECT(python)
- FILE(GLOB_RECURSE SRC src/*)
-
- find_package(Qt5 5.5.0 REQUIRED COMPONENTS Widgets)
--add_subdirectory(pybind11)
-+find_package(PythonLibs)
-+include_directories(${PYTHON_INCLUDE_DIRS})
-
- add_library(${PROJECT_NAME} SHARED ${SRC} ${PROJECT_NAME}.qrc metadata.json)
-
-@@ -14,8 +15,8 @@ target_include_directories(${PROJECT_NAME} PRIVATE src/)
- target_link_libraries(${PROJECT_NAME}
- PUBLIC
- Qt5::Widgets
-+ ${PYTHON_LIBRARIES}
- PRIVATE
-- pybind11::embed
- albert::lib
- xdg
- )
diff --git a/x11-misc/albert/files/albert-0.20.13-use-system-qhotkey-libraries-and-headers.patch b/x11-misc/albert/files/albert-0.20.13-use-system-qhotkey-libraries-and-headers.patch
deleted file mode 100644
index aaa3050b8079..000000000000
--- a/x11-misc/albert/files/albert-0.20.13-use-system-qhotkey-libraries-and-headers.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a48c253..ae5a549 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -45,8 +45,6 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
-
- set(QT_DEFAULT_MAJOR_VERSION 6)
- set(BUILD_SHARED_LIBS FALSE)
--add_subdirectory(lib/QHotkey EXCLUDE_FROM_ALL)
--target_compile_options(qhotkey PRIVATE -Wno-unused-parameter -Wno-shadow)
-
- set(TARGET_LIB ${PROJECT_NAME})
-