summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-30 21:55:53 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-30 22:02:09 +0100
commitf5357e664d721a1e5c1a89f733dc87d2fcd46bb7 (patch)
tree348a58f89f71cc885e5b49aadee6c22d14ae0980 /xfce-extra
parentxfce-base/thunar: Bump to 4.20.1 (diff)
downloadgentoo-f5357e664d721a1e5c1a89f733dc87d2fcd46bb7.tar.gz
gentoo-f5357e664d721a1e5c1a89f733dc87d2fcd46bb7.tar.bz2
gentoo-f5357e664d721a1e5c1a89f733dc87d2fcd46bb7.zip
xfce-extra/thunar-archive-plugin: Bump to 0.5.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/thunar-archive-plugin/Manifest1
-rw-r--r--xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/thunar-archive-plugin/Manifest b/xfce-extra/thunar-archive-plugin/Manifest
index ccd15d214aee..b07d8e909001 100644
--- a/xfce-extra/thunar-archive-plugin/Manifest
+++ b/xfce-extra/thunar-archive-plugin/Manifest
@@ -1 +1,2 @@
DIST thunar-archive-plugin-0.5.2.tar.bz2 371599 BLAKE2B a32e0d7c42ad075d2f40d815ca74b86bb0a9a3a2db8c4e2146d3e90b12d7ba4e72b7f75703adcc6aeca702b1124cbe833e80def9891498056c8e0c0483318cab SHA512 f334b960c623bc6c5736ba38d0e965b4e8d4f22fe857a66301c36c255701a702f839d6f63f67b37bc665066d75d787ea8159d4eed7561a2ecd98340bdcb65bc0
+DIST thunar-archive-plugin-0.5.3.tar.bz2 444382 BLAKE2B 08c78f8a94a2cb2b752e8e929a128dd8a7da4d22913c91ed4d9537b81f7a8732178294cabc805abf5f7127bb97caa651776c42d721d086f64ecb51614a9174ad SHA512 941af6925baee02b12e4f9424ad6f3a23175eab96e0fc8cf65456d8015d7912d5049956910047fb292294fe73311819d36028b25954c30c8a0377eccdb62c75a
diff --git a/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.3.ebuild b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.3.ebuild
new file mode 100644
index 000000000000..ae120e6c181d
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Archive plug-in for the Thunar filemanager"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/thunar/archive
+ https://gitlab.xfce.org/thunar-plugins/thunar-archive-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/thunar-1.7:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}