summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-24 18:26:56 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-24 18:49:38 +0100
commit829220ad57f5b27a0a10625aec2ef917a23731ef (patch)
tree12f1aeb0d19f3b6755e48a3baa864703bb9804a3 /xfce-extra
parentsys-apps/lm-sensors: drop 3.6.0-r1 (diff)
downloadgentoo-829220ad57f5b27a0a10625aec2ef917a23731ef.tar.gz
gentoo-829220ad57f5b27a0a10625aec2ef917a23731ef.tar.bz2
gentoo-829220ad57f5b27a0a10625aec2ef917a23731ef.zip
xfce-extra/xfce4-mailwatch-plugin: Bump to 1.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-mailwatch-plugin/Manifest b/xfce-extra/xfce4-mailwatch-plugin/Manifest
index 5b7af73ff88c..a4a420d055df 100644
--- a/xfce-extra/xfce4-mailwatch-plugin/Manifest
+++ b/xfce-extra/xfce4-mailwatch-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-mailwatch-plugin-1.3.1.tar.bz2 550836 BLAKE2B c4b53adec738308c37617b3512da8b3dbb6671b934c3ecdca904437b27374af935e92b2eb0d60b91ca42d8c2cb7d336ab687c7fa1d3106872ad368c2d13a3b7d SHA512 cc84c0511fff983283f6af132ff224f62373a1bb608f14b332a75f259f7842491b09f7d9f9d833cb31f81eb392a1b55fe4bf6da8a15b4c62abd2e9640392fb1d
+DIST xfce4-mailwatch-plugin-1.3.2.tar.bz2 712411 BLAKE2B 3fff577b5633e59e5d99e96af0134fff2f147590a985db0561a439614471ce75559206add986189fa02ee8e5f8daeb02deb79c12f59fc3cf8468b76d4bf0debd SHA512 97afde722984139cc5714612904915fc42e9b6905078529e3e367908f1880c5ce19f6fb5f381e6d5f3737633451e3a1f55105b1f5eaf6936b0108bd78490efd8
diff --git a/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.2.ebuild b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.2.ebuild
new file mode 100644
index 000000000000..823ec3f98eaf
--- /dev/null
+++ b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="An mail notification panel plug-in for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-mailwatch-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-mailwatch-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="ssl"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0:=
+ >=x11-libs/gtk+-3.22.0:3=
+ >=xfce-base/exo-0.11.0:=
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/libxfce4util-4.16.0:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+ ssl? ( >=net-libs/gnutls-2:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable ssl)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}