summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-31 23:30:43 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-31 23:31:29 +0100
commit914552b9e04847f6b4c5224953cf0c11b919ae1c (patch)
tree10d73386158e5ac3605d88e63756d2bd5c35eac4 /x11-wm
parentnet-analyzer/netwatch: Fix CFLAGS=-fno-common (diff)
downloadgentoo-914552b9e04847f6b4c5224953cf0c11b919ae1c.tar.gz
gentoo-914552b9e04847f6b4c5224953cf0c11b919ae1c.tar.bz2
gentoo-914552b9e04847f6b4c5224953cf0c11b919ae1c.zip
x11-wm/aewm: Fix CFLAGS=-fno-common
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Closes: https://bugs.gentoo.org/707680 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/aewm/aewm-1.3.12-r1.ebuild3
-rw-r--r--x11-wm/aewm/files/aewm-1.3.12-fno-common.patch25
2 files changed, 27 insertions, 1 deletions
diff --git a/x11-wm/aewm/aewm-1.3.12-r1.ebuild b/x11-wm/aewm/aewm-1.3.12-r1.ebuild
index c0d52983ed89..3efbc6c7a7ed 100644
--- a/x11-wm/aewm/aewm-1.3.12-r1.ebuild
+++ b/x11-wm/aewm/aewm-1.3.12-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,6 +26,7 @@ DEPEND="
"
PATCHES=(
"${FILESDIR}"/${P}-r1-gentoo.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_compile() {
diff --git a/x11-wm/aewm/files/aewm-1.3.12-fno-common.patch b/x11-wm/aewm/files/aewm-1.3.12-fno-common.patch
new file mode 100644
index 000000000000..e885161ce883
--- /dev/null
+++ b/x11-wm/aewm/files/aewm-1.3.12-fno-common.patch
@@ -0,0 +1,25 @@
+--- aedesk.c
++++ b/aedesk.c
+@@ -11,10 +11,6 @@
+
+ #define UMOD(x, y) ((((long)(x) % (long)(y)) + (y)) % (y))
+
+-Display *dpy;
+-Window root;
+-Atom net_cur_desk, net_num_desks;
+-
+ static unsigned long parse_desk(char *spec);
+
+ int main(int argc, char **argv)
+--- aepanel.c
++++ b/aepanel.c
+@@ -36,9 +36,6 @@
+ void sig_handler(int);
+ void set_strut(Window, strut_t *);
+
+-Atom net_wm_strut;
+-Atom net_wm_strut_partial;
+-Atom net_wm_wintype;
+ Atom net_wm_wintype_dock;
+
+ #define NAME_SIZE 48