summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/lwm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/lwm')
-rw-r--r--x11-wm/lwm/Manifest3
-rw-r--r--x11-wm/lwm/lwm-1.2.1.ebuild34
-rw-r--r--x11-wm/lwm/lwm-1.2.2.ebuild45
-rw-r--r--x11-wm/lwm/lwm-1.2.3.ebuild48
-rw-r--r--x11-wm/lwm/metadata.xml10
5 files changed, 140 insertions, 0 deletions
diff --git a/x11-wm/lwm/Manifest b/x11-wm/lwm/Manifest
new file mode 100644
index 000000000000..fc3b8e17d871
--- /dev/null
+++ b/x11-wm/lwm/Manifest
@@ -0,0 +1,3 @@
+DIST lwm-1.2.1.tar.gz 46309 SHA256 e50538831655bb0fe41badc35477c12e6dff5becfda365bdb759f230ee0d5af2
+DIST lwm-1.2.2.tar.gz 47715 SHA256 3567b53f5de8c0bb23a83efa94a256547fc44f677bc15b9449599aeac7aaad7d SHA512 18d0e9923b8c24164b2a8ecbaf48e0120ae3e9be69a5a43716b45e605e740f19c96586dad64506076affcfba7b4e1eeef547a1cb8239ea108c40f80ef2f90419 WHIRLPOOL 98e0c3f5e2d27825df60a82343fb09b453ccbca1bbdf2e8bdb0207baa2ff2ef2665254dbefcc97ef9bd4ce85fa118e5bef73517ad57b9c40f792f82903f96499
+DIST lwm-1.2.3.tar.gz 47253 SHA256 f27587d8f8b77378050917735a69dd9160d9903a4cfb3e23a62991023fc5e558 SHA512 2c699050b3d8ade258a5ff21c0f7a427470bee9a5c8a92f031c4e74f3dcd78f00e181c04ea00bbd4d0dafd60eee5e603b247b75c21faf1017d9f61fb49702d03 WHIRLPOOL 86e8708ae1900ab49382a86729902d15b603eb435d12baceab97892a0757fdbe261cb22d965bd34bae578fc78e3fe84224ca59ffe4ab814fb2c3d7a9e52fcb8e
diff --git a/x11-wm/lwm/lwm-1.2.1.ebuild b/x11-wm/lwm/lwm-1.2.1.ebuild
new file mode 100644
index 000000000000..6f8326f26313
--- /dev/null
+++ b/x11-wm/lwm/lwm-1.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+IUSE=""
+
+DESCRIPTION="The ultimate lightweight window manager"
+SRC_URI="http://www.jfc.org.uk/files/lwm/${P}.tar.gz"
+HOMEPAGE="http://www.jfc.org.uk/software/lwm.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ppc sparc x86 ~x86-fbsd"
+
+RDEPEND="x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ x11-misc/imake"
+
+src_compile() {
+ xmkmf || die
+ emake lwm || die
+}
+
+src_install() {
+
+ dobin lwm
+
+ newman lwm.man lwm.1
+ dodoc AUTHORS BUGS ChangeLog INSTALL README TODO
+}
diff --git a/x11-wm/lwm/lwm-1.2.2.ebuild b/x11-wm/lwm/lwm-1.2.2.ebuild
new file mode 100644
index 000000000000..28ea91e910d2
--- /dev/null
+++ b/x11-wm/lwm/lwm-1.2.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="The ultimate lightweight window manager"
+SRC_URI="http://www.jfc.org.uk/files/lwm/${P}.tar.gz"
+HOMEPAGE="http://www.jfc.org.uk/software/lwm.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ x11-misc/imake"
+
+src_prepare() {
+ sed -i -e "s/(SMLIB)/& -lICE/g" Imakefile || die #370127
+ xmkmf || die
+}
+
+src_compile() {
+ emake \
+ EXTRA_LDOPTIONS="${CFLAGS} ${LDFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)" \
+ lwm || die
+}
+
+src_install() {
+ dobin lwm
+
+ newman lwm.man lwm.1
+ dodoc AUTHORS BUGS ChangeLog
+}
diff --git a/x11-wm/lwm/lwm-1.2.3.ebuild b/x11-wm/lwm/lwm-1.2.3.ebuild
new file mode 100644
index 000000000000..ef03f4782b4f
--- /dev/null
+++ b/x11-wm/lwm/lwm-1.2.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="The ultimate lightweight window manager"
+SRC_URI="http://www.jfc.org.uk/files/lwm/${P}.tar.gz"
+HOMEPAGE="http://www.jfc.org.uk/software/lwm.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+"
+DEPEND="
+ ${RDEPEND}
+ x11-misc/imake
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ sed -i -e "s/(SMLIB)/& -lICE/g" Imakefile || die #370127
+ xmkmf || die
+}
+
+src_compile() {
+ emake \
+ EXTRA_LDOPTIONS="${CFLAGS} ${LDFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)" \
+ lwm || die
+}
+
+src_install() {
+ dobin lwm
+
+ newman lwm.man lwm.1
+ dodoc AUTHORS BUGS ChangeLog
+}
diff --git a/x11-wm/lwm/metadata.xml b/x11-wm/lwm/metadata.xml
new file mode 100644
index 000000000000..747591635cac
--- /dev/null
+++ b/x11-wm/lwm/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <longdescription>
+ lwm is a window manager for X that tries to keep out of your face.
+ There are no icons, no button bars, no icon docks, no root menus,
+ no nothing.
+ </longdescription>
+</pkgmetadata>