summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-10-23 17:46:51 +0200
committerPacho Ramos <pacho@gentoo.org>2022-10-23 18:06:43 +0200
commit1c94f01e5d61bebf24849ca93c7eeb376dae4b91 (patch)
tree93282d5e32fbc461294ac885908e7aef9203e10a /x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-22.10.2.ebuild
parentx11-themes/QGnomePlatform: make wayland optional (diff)
downloadgentoo-1c94f01e5d61bebf24849ca93c7eeb376dae4b91.tar.gz
gentoo-1c94f01e5d61bebf24849ca93c7eeb376dae4b91.tar.bz2
gentoo-1c94f01e5d61bebf24849ca93c7eeb376dae4b91.zip
x11-themes/ubuntu-wallpapers: add 22.10.2
Closes: https://bugs.gentoo.org/877511 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-22.10.2.ebuild')
-rw-r--r--x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-22.10.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-22.10.2.ebuild b/x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-22.10.2.ebuild
new file mode 100644
index 000000000000..42a449c95f43
--- /dev/null
+++ b/x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-22.10.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Ubuntu wallpapers"
+HOMEPAGE="https://launchpad.net/ubuntu/+source/ubuntu-wallpapers"
+MY_P="${PN}_${PV}"
+SRC_URI="mirror://ubuntu/pool/main/u/${PN}/${MY_P}.orig.tar.gz"
+
+# Review COPYING file for updates
+LICENSE="CC-BY-SA-3.0"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+BDEPEND=""
+
+S="${WORKDIR}/${MY_P/_/-}"
+
+SLOT="0"
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/backgrounds
+ doins *.jpg *.png
+
+ insinto /usr/share/backgrounds/contest
+ doins contest/*.xml
+
+ for i in *.xml.in; do
+ sed -i 's/_name/name/g' ${i}
+ insinto /usr/share/gnome-background-properties
+ newins ${i} ${i/.in/}
+ done
+
+ einstalldocs
+}