summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-08-15 19:25:59 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-08-15 20:04:35 -0400
commitd5f4929e0ac3f31101d34ea8cfb5d6ecf1dc38cf (patch)
treef61cf0998051452f8beaf4392c91079e4f2315d2 /x11-terms
parentsys-devel/gcc: add 12.4.1_p20240815 (diff)
downloadgentoo-d5f4929e0ac3f31101d34ea8cfb5d6ecf1dc38cf.tar.gz
gentoo-d5f4929e0ac3f31101d34ea8cfb5d6ecf1dc38cf.tar.bz2
gentoo-d5f4929e0ac3f31101d34ea8cfb5d6ecf1dc38cf.zip
x11-terms/kitty: remove redundant workaround
Still an issue, but workaround is now handled by go-env.eclass. Bug: https://bugs.gentoo.org/924436 Thanks-to: Sam James <sam@gentoo.org> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty/kitty-0.34.1.ebuild12
-rw-r--r--x11-terms/kitty/kitty-0.35.2.ebuild12
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild12
3 files changed, 3 insertions, 33 deletions
diff --git a/x11-terms/kitty/kitty-0.34.1.ebuild b/x11-terms/kitty/kitty-0.34.1.ebuild
index 2fd93cddd02c..cdd3efe60acc 100644
--- a/x11-terms/kitty/kitty-0.34.1.ebuild
+++ b/x11-terms/kitty/kitty-0.34.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit edo flag-o-matic go-env optfeature multiprocessing
+inherit edo go-env optfeature multiprocessing
inherit python-single-r1 toolchain-funcs xdg
if [[ ${PV} == 9999 ]]; then
@@ -136,16 +136,6 @@ src_compile() {
local -x GOFLAGS="-p=$(makeopts_jobs) -v -x -buildvcs=false"
use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
- # workaround link errors with Go + gcc + -g3 (bug #924436),
- # retry now and then to see if can be dropped
- tc-is-gcc &&
- CGO_CFLAGS=$(
- CFLAGS=${CGO_CFLAGS}
- replace-flags -g3 -g
- replace-flags -ggdb3 -ggdb
- printf %s "${CFLAGS}"
- )
-
local conf=(
--disable-link-time-optimization
--ignore-compiler-warnings
diff --git a/x11-terms/kitty/kitty-0.35.2.ebuild b/x11-terms/kitty/kitty-0.35.2.ebuild
index ec0e87ecfb7d..6ee50e0f8ad0 100644
--- a/x11-terms/kitty/kitty-0.35.2.ebuild
+++ b/x11-terms/kitty/kitty-0.35.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..13} )
-inherit edo flag-o-matic go-env optfeature multiprocessing
+inherit edo go-env optfeature multiprocessing
inherit python-single-r1 toolchain-funcs xdg
if [[ ${PV} == 9999 ]]; then
@@ -136,16 +136,6 @@ src_compile() {
local -x GOFLAGS="-p=$(makeopts_jobs) -v -x -buildvcs=false"
use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
- # workaround link errors with Go + gcc + -g3 (bug #924436),
- # retry now and then to see if can be dropped
- tc-is-gcc &&
- CGO_CFLAGS=$(
- CFLAGS=${CGO_CFLAGS}
- replace-flags -g3 -g
- replace-flags -ggdb3 -ggdb
- printf %s "${CFLAGS}"
- )
-
local conf=(
--disable-link-time-optimization
--ignore-compiler-warnings
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index f90f58f4b109..9e678478d906 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..13} )
-inherit edo flag-o-matic go-env optfeature multiprocessing
+inherit edo go-env optfeature multiprocessing
inherit python-single-r1 toolchain-funcs xdg
if [[ ${PV} == 9999 ]]; then
@@ -137,16 +137,6 @@ src_compile() {
local -x GOFLAGS="-p=$(makeopts_jobs) -v -x -buildvcs=false"
use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
- # workaround link errors with Go + gcc + -g3 (bug #924436),
- # retry now and then to see if can be dropped
- tc-is-gcc &&
- CGO_CFLAGS=$(
- CFLAGS=${CGO_CFLAGS}
- replace-flags -g3 -g
- replace-flags -ggdb3 -ggdb
- printf %s "${CFLAGS}"
- )
-
local conf=(
--disable-link-time-optimization
--ignore-compiler-warnings