summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-10-30 15:43:14 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-10-30 15:59:28 -0400
commitd176c430ec97ab40b41a8fa5ae8e4ec85babdb77 (patch)
treed83a2e73a9e5d4e56def42d0f069763bb0e4404d /x11-terms
parentx11-terms/kitty-terminfo: drop 0.36.2, 0.36.3 (diff)
downloadgentoo-d176c430ec97ab40b41a8fa5ae8e4ec85babdb77.tar.gz
gentoo-d176c430ec97ab40b41a8fa5ae8e4ec85babdb77.tar.bz2
gentoo-d176c430ec97ab40b41a8fa5ae8e4ec85babdb77.zip
x11-terms/kitty-shell-integration: add 0.37.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest1
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.37.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index 20a779bcffb7..6a2eeb41e908 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1,2 +1,3 @@
DIST kitty-0.35.2.tar.xz 8220608 BLAKE2B 277803c7036890af34f2e0497ab1d33cb578cba4bfba425d6699e02e2106cde4e10f7dcc6859ce7eea1b4f34795a2f5180328665450ccb49d8a6da4183fa4f50 SHA512 edc78046f942965c823a1202a6d7c85cc2d2acb376824a0f5224d4ba6f48ed0978a00eb7a3e1e6053622a7d5fdcf80009ecfb61a63272cf407dd30f828f47b56
DIST kitty-0.36.4.tar.xz 8875060 BLAKE2B 530b11a719360997230ef12dc857dea975ccfce1f111c23ccabf392bd463ebe3ae80aef8cb8a1f7c3877e7847d750ad04f6185c0d8e05ac9770f2b7dfc407bf5 SHA512 3ffabb181903495d6a11a8b790e75331a5ab0986de0b7a7958ea7dfee724c29aee88c31672e2f7711d3fc51a81e1a3c84e4469228872aa62df840ded2c0d5218
+DIST kitty-0.37.0.tar.xz 8881224 BLAKE2B ad1fb416ac692dcaf6b05306f4cc5838db8e0c172bab483ee52cddf86c21f864071d22d0f122031635227379957c9bd7fd2f4e971c2ddc74f99ad2e6212cb440 SHA512 786b3361147c988e7bbafcc0706940b8dbd172b07b88c1d6b49ae4a3caefba2cb72a05bf4f173ac963989be6d435bef60d6f8e8abb76362f8a07c231cfa04e31
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.37.0.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.37.0.ebuild
new file mode 100644
index 000000000000..a50a1338ca92
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.37.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash/,/etc/bash/bashrc.d/90-}kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}