summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-29 12:20:35 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-29 12:20:40 +0100
commitf49167d2652bb5859b2d8e2ee3c4f366af4f0660 (patch)
tree6de7037ed3f33c22d7bbee731a810db34b7e9c53 /x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild
parentdev-python/xdoctest: Restore accidentally removed HOMEPAGE (diff)
downloadgentoo-f49167d2652bb5859b2d8e2ee3c4f366af4f0660.tar.gz
gentoo-f49167d2652bb5859b2d8e2ee3c4f366af4f0660.tar.bz2
gentoo-f49167d2652bb5859b2d8e2ee3c4f366af4f0660.zip
x11-plugins/pidgin-sipe: Don't install .la files
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild')
-rw-r--r--x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild b/x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild
new file mode 100644
index 000000000000..7aa6dbaf79c1
--- /dev/null
+++ b/x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
+HOMEPAGE="http://sipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="dbus debug kerberos ocs2005-message-hack openssl telepathy voice"
+
+RDEPEND="
+ dev-libs/gmime:2.6
+ dev-libs/libxml2
+ openssl? ( dev-libs/openssl:= )
+ !openssl? ( dev-libs/nss )
+ kerberos? ( virtual/krb5 )
+ voice? (
+ >=dev-libs/glib-2.28.0
+ >=net-libs/libnice-0.1.0
+ media-libs/gstreamer:1.0
+ net-libs/farstream:0.2
+ )
+ !voice? (
+ >=dev-libs/glib-2.12.0:2
+ )
+ net-im/pidgin[dbus?]
+ telepathy? (
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.61
+ >=dev-libs/glib-2.28:2
+ >=net-libs/telepathy-glib-0.18.0
+ )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myeconfargs=(
+ --enable-purple
+ --disable-quality-check
+ $(use_enable telepathy)
+ $(use_enable debug)
+ $(use_enable ocs2005-message-hack)
+ $(use_with dbus)
+ $(use_with kerberos krb5)
+ $(use_with voice vv)
+ $(use_enable !openssl nss)
+ $(use_enable openssl)
+ )
+ econf "${myeconfsrgs[@]}"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS TODO README
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}