summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCristian Othón Martínez Vera <cfuga@cfuga.mx>2023-06-23 15:44:55 -0600
committerJoonas Niilola <juippis@gentoo.org>2023-07-14 09:52:18 +0300
commit92fb4cb5f29e7ef6f0fa932a82b7021ddec9c49f (patch)
tree08b23667077f3d9f0f271bb1ab982e551ff96474 /x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild
parentdev-python/pillow: Add missing dev-python/wheel dep (diff)
downloadgentoo-92fb4cb5f29e7ef6f0fa932a82b7021ddec9c49f.tar.gz
gentoo-92fb4cb5f29e7ef6f0fa932a82b7021ddec9c49f.tar.bz2
gentoo-92fb4cb5f29e7ef6f0fa932a82b7021ddec9c49f.zip
x11-plugins/pidgin-sipe: fix bashisms in configure script
Bug: https://bugs.gentoo.org/730118 Signed-off-by: Cristian Othón Martínez Vera <cfuga@cfuga.mx> Closes: https://github.com/gentoo/gentoo/pull/31586 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild')
-rw-r--r--x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild b/x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild
index 4b73a6e3e9c1..bbdf8d917086 100644
--- a/x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild
+++ b/x11-plugins/pidgin-sipe/pidgin-sipe-1.25.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,6 +7,8 @@ DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
HOMEPAGE="http://sipe.sourceforge.net/"
SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
+inherit autotools
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
@@ -43,6 +45,13 @@ BDEPEND="
virtual/pkgconfig
"
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-1.25.0-bashisms.patch
+
+ eautoreconf
+ default
+}
+
src_configure() {
local myeconfargs=(
--enable-purple