summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-07-23 12:03:16 +0200
committerJeroen Roovers <jer@gentoo.org>2019-07-23 12:03:34 +0200
commit5601cabf5c3865f8b3267162eb3588f89bda2c91 (patch)
treeb39b0ff2388055fb9d8c74fcaa4c02126ab3eb4d /x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild
parentx11-misc/i3lock: Version 2.12 (diff)
downloadgentoo-5601cabf5c3865f8b3267162eb3588f89bda2c91.tar.gz
gentoo-5601cabf5c3865f8b3267162eb3588f89bda2c91.tar.bz2
gentoo-5601cabf5c3865f8b3267162eb3588f89bda2c91.zip
x11-misc/xdesktopwaves: Version 1.4
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild')
-rw-r--r--x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild b/x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild
new file mode 100644
index 000000000000..901b11eb7789
--- /dev/null
+++ b/x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit desktop toolchain-funcs
+
+DESCRIPTION="A cellular automata setting the background of your X Windows desktop under water"
+HOMEPAGE="http://xdesktopwaves.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+RDEPEND="
+ x11-libs/libXext
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4-gentoo.patch
+)
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+ emake
+ emake -C xdwapi
+}
+
+src_install() {
+ dobin xdesktopwaves xdwapi/xdwapidemo
+ doman xdesktopwaves.1
+ insinto /usr/share/pixmaps
+ doins xdesktopwaves.xpm
+ make_desktop_entry xdesktopwaves
+ einstalldocs
+}