summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/blockdpy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/blockdpy')
-rw-r--r--x11-misc/blockdpy/Manifest1
-rw-r--r--x11-misc/blockdpy/blockdpy-1.ebuild57
-rw-r--r--x11-misc/blockdpy/metadata.xml7
3 files changed, 65 insertions, 0 deletions
diff --git a/x11-misc/blockdpy/Manifest b/x11-misc/blockdpy/Manifest
new file mode 100644
index 000000000000..f98f0e7fd351
--- /dev/null
+++ b/x11-misc/blockdpy/Manifest
@@ -0,0 +1 @@
+DIST blockdpy.c 10580 SHA256 32fc5c822db84d99dced36369695c64664d8075d1a7cf6cd2305f8f79cc8a004
diff --git a/x11-misc/blockdpy/blockdpy-1.ebuild b/x11-misc/blockdpy/blockdpy-1.ebuild
new file mode 100644
index 000000000000..252c06355c14
--- /dev/null
+++ b/x11-misc/blockdpy/blockdpy-1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to block access via the physical display while x11vnc is running"
+HOMEPAGE="http://www.karlrunge.com/x11vnc/blockdpy.c"
+SRC_URI="http://www.karlrunge.com/x11vnc/blockdpy.c"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXext"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp "${DISTDIR}"/blockdpy.c blockdpy.c
+
+ # Add includes to avoid QA warnings.
+ sed -i '/#include <stdio.h>/i#include <stdlib.h>' blockdpy.c
+ sed -i '/#include <stdio.h>/i#include <string.h>' blockdpy.c
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o blockdpy blockdpy.c -lX11 -lXext ||
+ die "compile failed"
+
+ # Create README from head comment in source.
+ sed -n '1,/^ *\*\//s/^[ -]*\*[ \/]*//p' < blockdpy.c > README
+}
+
+src_install() {
+ dobin blockdpy || die "install failed"
+ dodoc README
+}
+
+pkg_postinst() {
+ # Just warn about missing xlock instead of requiring it in case
+ # the user wants to use something else.
+ if ! [ -x /usr/bin/xlock ]; then
+ ewarn 'The xlock executable was not found.'
+ ewarn 'blockdpy runs "xlock" as the screen-lock program by default.'
+ ewarn 'You should either install x11-misc/xlockmore or override the'
+ ewarn 'default by calling blockdpy with the -lock option or by'
+ ewarn 'setting the XLOCK_CMD environment variable.'
+ ewarn
+ ewarn " Examples: blockdpy -lock 'xscreensaver-command -lock'"
+ ewarn " blockdpy -lock 'kdesktop_lock --forcelock'"
+ ewarn
+ fi
+}
diff --git a/x11-misc/blockdpy/metadata.xml b/x11-misc/blockdpy/metadata.xml
new file mode 100644
index 000000000000..a40624fba8f0
--- /dev/null
+++ b/x11-misc/blockdpy/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>