summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-25 12:28:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-25 16:06:50 +0100
commitcff308d862a376ce9671288b88ef4c6b1c2eaeeb (patch)
tree4526340df0629f2cc54e2ccebf54bc08a49a6608 /x11-libs/tslib/tslib-1.22.ebuild
parentxfce-base/xfce4-panel: Bump to 4.16.2 (diff)
downloadgentoo-cff308d862a376ce9671288b88ef4c6b1c2eaeeb.tar.gz
gentoo-cff308d862a376ce9671288b88ef4c6b1c2eaeeb.tar.bz2
gentoo-cff308d862a376ce9671288b88ef4c6b1c2eaeeb.zip
x11-libs/tslib: 1.22 version bump, switch to cmake.eclass
Released on 2020-07-01. Bug: https://bugs.gentoo.org/618654 Closes: https://bugs.gentoo.org/770559 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-libs/tslib/tslib-1.22.ebuild')
-rw-r--r--x11-libs/tslib/tslib-1.22.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/x11-libs/tslib/tslib-1.22.ebuild b/x11-libs/tslib/tslib-1.22.ebuild
new file mode 100644
index 000000000000..1fadd84c49a0
--- /dev/null
+++ b/x11-libs/tslib/tslib-1.22.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Touchscreen Access Library"
+HOMEPAGE="https://github.com/kergoth/tslib"
+SRC_URI="https://github.com/libts/tslib/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2 uinput? ( GPL-2+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="evdev sdl uinput"
+
+BDEPEND="
+ evdev? ( virtual/pkgconfig )
+"
+DEPEND="
+ evdev? ( dev-libs/libevdev[${MULTILIB_USEDEP}] )
+ sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS NEWS README{,.md} )
+
+PATCHES=( "${FILESDIR}/${PN}-1.21-optional-utils.patch" )
+
+src_configure() {
+ my_configure() {
+ local mycmakeargs=(
+ -Denable-input-evdev=$(usex evdev)
+ -DENABLE_TOOLS=$(usex uinput $(multilib_is_native_abi && echo ON || echo OFF) OFF)
+ -DENABLE_UTILS=$(multilib_is_native_abi && echo ON || echo OFF)
+ -Denable-arctic2=ON
+ -Denable-collie=ON
+ -Denable-corgi=ON
+ -Denable-cy8mrln-palmpre=ON
+ -Denable-dejitter=ON
+ -Denable-dmc=ON
+ -Denable-dmc_dus3000=ON
+ -Denable-galax=ON
+ -Denable-h3600=ON
+ -Denable-input=ON
+ -Denable-linear-h2200=ON
+ -Denable-linear=ON
+ -Denable-mk712=ON
+ -Denable-one-wire-ts-input=ON
+ -Denable-pthres=ON
+ -Denable-tatung=ON
+ -Denable-ucb1x00=ON
+ -Denable-variance=ON
+ )
+ multilib_is_native_abi && mycmakeargs+=( -Dwith-sdl=$(usex sdl) )
+
+ cmake_src_configure
+ }
+ multilib_parallel_foreach_abi my_configure
+}